<!doctype html>
<html lang="en">
<head>	
	        <!-- <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> -->
		<meta http-equiv='Content-Type' content='text/html; charset=UTF-8' /> 
		<title>Gamasutra: Svyatoslav Cherkasov's Blog - Porting Graveyard Keeper to consoles and mobiles</title>
	<meta name="pagecaching" content="757" />
			<meta name="keywords" content="game development, game developer, game programming, game programmer, videogame, artificial intelligence, 3D animation, game design, 3D modeling, game business, game jobs, game directory, game development software, game technology, 3D technology, game producer, game audio, game animation, virtual reality, digital entertainment, PC game, Xbox game, game news, new game, arcade development, Nintendo development, Playstation development, Playstation 2, PS2, Dreamcast development, Game Developer magazine, Computer Game Developers Conference, Game Developers Conference, Independent Game Developers Conference, CMP Game Media Group, game industry research, online game development, digital assets, free textures, free 3D models, free shaders, Gamasutra Exchange, 3D Studio Max textures" /><meta name="description" content="In this article I tried to summarize our experience in porting a PC game made in Unity for mobiles (iOS / Android) and consoles (XBox One / PS4 / Nint" />
		<!--[if lt IE 9]>
		<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->
	<style>
		
			.cke_source{
				white-space:normal !important;
			}
			.hide_phone > iframe {
				width: 100%;
			}
			@media only screen and (max-width:479px){
				.hide_phone > iframe {
					height: auto;
				}
				.embeddedContent iframe, .page_data_1 iframe {
					width: 100%;
				}
			}
			.properties ul li {
				padding: 5px 28px !important;
			}
			.formElement label.questionLabel p.description {
				font-weight: normal;
				padding: 0 !important;
			}
			div#rightlinks ul {
				padding: 0 15px !important;
			}
			.article img {
				max-width: 100% !important;
			}
			@media screen and (max-width: 425px) {
				blockquote{
					float:none !important;
					clear:both;
				}
			}
		

	</style>
	<!-- CSS -->
        
        
<meta property="fb:app_id" content="1424004174373289"/>		
        			 <meta property="og:type" content="article"/>
			 <meta property="og:url"  content="https://gamasutra.com/blogs/SvyatoslavCherkasov/20190627/345688/Porting_Graveyard_Keeper_to_consoles_and_mobiles.php" />
			 <meta property="og:title" content="Porting Graveyard Keeper to consoles and mobiles" />
                   	 	
                                <meta name="og:image" content="https://gamasutra.com/blogs/edit/img/portrait/6628/portrait.png" />
                         			 <meta property="og:description" content="In this article I tried to summarize our experience in porting a PC game made in Unity for mobiles (iOS / Android) and consoles (XBox One / PS4 / Nintendo Switch)." />
				
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:site" content="@gamasutra" />
		<meta name="twitter:creator" content="@gamasutra" />
					<meta name="twitter:title" content="Porting Graveyard Keeper to consoles and mobiles" />
			<meta name="twitter:description" content="In this article I tried to summarize our experience in porting a PC game made in Unity for mobiles (iOS / Android) and consoles (XBox One / PS4 / Nintendo Switch)." />
			<meta name="twitter:creator" content="@gamasutra" />
			<meta name="twitter:url" content="https://gamasutra.com/blogs/SvyatoslavCherkasov/20190627/345688/Porting_Graveyard_Keeper_to_consoles_and_mobiles.php" />
			<meta name="twitter:image" content="https://gamasutra.com/blogs/edit/img/portrait/6628/portrait.png" />
		
        
                	<link rel="canonical" href="https://gamasutra.com/blogs/SvyatoslavCherkasov/20190627/345688/Porting_Graveyard_Keeper_to_consoles_and_mobiles.php" />
                <link rel="alternate" type="application/rss+xml" title="Gamasutra Article Feed" href="http://feeds.feedburner.com/GamasutraFeatureArticles/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra News Feed" href="http://feeds.feedburner.com/GamasutraNews/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Columns Feed" href="http://feeds.feedburner.com/GamasutraColumns/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Jobs Feed" href="http://feeds.feedburner.com/GamasutraJobs/" />
        <!-- link href="https://twimgs.com/gamasutra/css/minified.css" rel="stylesheet" type="text/css" / -->
        <link href="https://twimgs.com/nojitter/gama/css/gama_unminified.css?v1" rel="stylesheet" type="text/css" />
		<style>
			
				#div-gpt-ad-Ltile1 {
					margin-top: 10px;
				}
			
		</style>
        
                         <meta name="node" content="Gama1"/>
            
        <meta name="pagecaching" content="388"/>
        		<script language="JavaScript" type="text/javascript" src="https://epromos.ubmcanon.com/VisitorAPI.js?ormzkk"></script>
        <script type="text/javascript" src="https://epromos.ubmcanon.com/at.js?ormzkk"></script>
        <script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/redesign_comments.js"></script>
		<script src="//code.jquery.com/jquery-1.8.2.min.js"></script>
		<script type="text/javascript" async src="https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.5/MathJax.js?config=TeX-MML-AM_CHTML"></script>
		<script type="text/javascript"> 
        
		function checkMail(obj){
	 
		   var think_opt_out = document.getElementById('Think_Opt_Out');
	 
		   if (document.getElementById('Think_Opt_Out').checked) {
	 
				 document.getElementById('Think_Opt_In').value = 0;
		   } else {
	 
				 document.getElementById('Think_Opt_In').value = 1;
		   }
		   var firstname = document.getElementById('firstname').value;
		   if (firstname == ""){
				 alert('Please provide your first name');
				 return false;
		   }
	 
		   if (document.getElementById('lastname').value == ''){
				 alert("Please provide your lastt name");
				 return false;
		   }
	 
	 
		   var x = document.getElementById('EmailAddr').value;
	 
		   var filter  = /^([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4})+$/;
		   if (filter.test(x)) { return true; }
		   else  { alert('Invalid Email Address detected. Please correct.'); return false; }
	 
	 
		}
		 
		</script>
        <script type="text/javascript" src="https://twimgs.com/gamasutra/js/md5.js"></script>

        

        <script type="text/javascript">
        var adrand = parseInt(Math.random()*1000000000, 10);
        var adkeys = "key1+key2+key3+key4";
        </script>

        	<!-- Mobile Specific Metas -->
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /> 
	
	<script type="text/javascript">
            
		var browser			= navigator.userAgent;
		var browserRegex	= /(Android|BlackBerry|IEMobile|Nokia|iP(ad|hone|od)|Opera M(obi|ini))/;
		var isMobile		= false;
		if(browser.match(browserRegex)) {
			isMobile			= true;
			
		}
        
	</script>
        <!-- Start Visual Website Optimizer Asynchronous Code -->
        <script type='text/javascript'>
        
        var _vwo_code=(function(){
        var account_id=32069,
        settings_tolerance=2000,
        library_tolerance=2500,
        use_existing_jquery=false,
        // DO NOT EDIT BELOW THIS LINE
        f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
        
        </script>
        <!-- End Visual Website Optimizer Asynchronous Code -->
       
        
        <!-- Start HeatMap.me Code -->
		<script type='text/javascript'>
		(function(h,e,a,t,m,p)
		{ m=e.createElement(a);m.async=!0;m.src=t; p=e.getElementsByTagName(a)[0];p.parentNode.insertBefore(m,p); }
		)(window,document,'script','https://u.heatmap.it/log.js');
		</script>
		<!-- End HeatMap.me Code -->
        
        
				
		<!-- Start: GPT Sync -->
        <script>
		
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.slots = googletag.slots || {};
        var gptadslots=[];
		
        </script>
        <script src="//www.googletagservices.com/tag/js/gpt.js"></script>

        <script type="text/javascript">
              
                      googletag.pubads().setTargeting('kw',['programming','production','console-pc','serious','indie','smartphone-tablet']);
                                            googletag.pubads().setTargeting('aid',['345688']);
          		
				if (document.documentElement.clientWidth > 767)
				{
				//Adslot 19 declaration
		
					gptadslots[19]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[2,2]],'div-gpt-ad-welcome').setTargeting('pos',['welcome']).addService(googletag.pubads());
		
				}
				else
				{
				//Adslot 20 declaration
		
					gptadslots[20]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[7,7]],'div-gpt-ad-mi').setTargeting('pos',['mi']).addService(googletag.pubads());
		
				}
				  
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		
					gptadslots[1]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[1,2]],'div-gpt-ad-skin').setTargeting('pos',['skin']).addService(googletag.pubads());

					gptadslots[2]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[728,90]],'div-gpt-ad-top').setTargeting('pos',['top']).addService(googletag.pubads());
		
				}else{ 
		
					gptadslots[13]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[300,50]],'div-gpt-ad-mobile_leaderboard').setTargeting('pos',['mobile_leaderboard']).addService(googletag.pubads());
		

		}
		            
          //Adslot 1 declaration
       

				  //Adslot 2 declaration
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 3 declaration
					 gptadslots[3]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,59]],'div-gpt-ad-button1').setTargeting('pos',['button1']).addService(googletag.pubads());

					 //Adslot 4 declaration
					 gptadslots[4]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,59]],'div-gpt-ad-button2').setTargeting('pos',['button2']).addService(googletag.pubads());

					 //Adslot 5 declaration
					 gptadslots[5]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,409]],'div-gpt-ad-callout').setTargeting('pos',['callout']).addService(googletag.pubads());
		

				}
		
						
			//Adslot 6 declaration
			gptadslots[6]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[300,250]],'div-gpt-ad-rec1').setTargeting('pos',['rec1']).addService(googletag.pubads());
						
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 7 declaration
					 gptadslots[7]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[160,600]],'div-gpt-ad-sky1').setTargeting('pos',['sky1']).addService(googletag.pubads());

					 //Adslot 8 declaration
					 gptadslots[8]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[160,160]],'div-gpt-ad-Ltile1').setTargeting('pos',['Ltile1']).addService(googletag.pubads());

					 //Adslot 9 declaration
					 gptadslots[9]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,177]],'div-gpt-ad-custom1').setTargeting('pos',['custom1']).addService(googletag.pubads());

					
					 //Adslot 11 declaration
					 gptadslots[11]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,177]],'div-gpt-ad-custom3').setTargeting('pos',['custom3']).addService(googletag.pubads());
					  
          
		
		}
		
		 gptadslots[14]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[3,3]],'div-gpt-ad-ribbon').setTargeting('pos',['ribbon']).addService(googletag.pubads());
		 		 		 													//Adslot 21 declaration
			gptadslots[21]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[8,2]],'div-gpt-ad-native').setTargeting('pos',['native']).addService(googletag.pubads());
			//Adslot 22 declaration
			gptadslots[22]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[8,4]],'div-gpt-ad-insight').setTargeting('pos',['insight']).addService(googletag.pubads());
			//Adslot 23 declaration
			gptadslots[23]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[4,4]],'div-gpt-ad-video').setTargeting('pos',['video']).addService(googletag.pubads());
		

         googletag.pubads().enableSingleRequest();
		 googletag.pubads().collapseEmptyDivs();
         		 googletag.pubads().enableAsyncRendering();
         googletag.enableServices();
        </script>
        <!-- End: GPT -->
	
	<script type="text/javascript">
	
	  var _AdsNativeOpts =
	  {
	
		keywords: ['consolepc']
	
	  };
	
	</script>
        
         		<script type="text/javascript">
 		
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-48094207-1']);
			_gaq.push(['_trackPageview']);
			(function()
			{ var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); }
			)();
		
		</script>
		<link rel="stylesheet" href="https://i.ubm-us.net/oas/nativead/css/game_nativead.css" />
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/nativead.js"></script>
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/game_nativead.js"></script>
		<link rel="stylesheet" href="https://twimgs.com/nojitter/gama/css/informa-iribbon.css" />
	<script src="https://twimgs.com/nojitter/gama/js/informa-iribbon.js"></script>
</head>
<body >
	<!-- Informa Branding code goes here-->
	<div id="iribbon-container" class="content-body-wrapper" style="padding-top:10px; opacity:0;">
			<button id="iribbon-title" title="show/hide" class="inactive">Informa</button>
			<div id="iribbon-detail" class="ribbon-hide" style="">
    		<div id="iribbon-left">
        		<p>Gamasutra is part of the Informa Tech Division of Informa PLC</p>
        		<ul>
            		<li class="iribbon-mainlink"><a href="http://informa.com/" tabindex="-1" class='iribbon-opacity-out'>Informa PLC</a></li>
            		<li><a href="http://informa.com/About-Us/" tabindex="-1" class='iribbon-opacity-out'>About us</a></li>
            		<li><a href="http://informa.com/Investors/" tabindex="-1" class='iribbon-opacity-out'>Investor relations</a></li>
            		<li><a href="http://informa.com/Talent/" tabindex="-1" class='iribbon-opacity-out'>Talent</a></li>
        		</ul>
    		</div>
    			<div id="iribbon-right">
        			<p>This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them. Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.</p>
    			</div>
			</div>
	</div>
	<!-- Informa Branding code goes here-->
	<!-- Beginning Sync AdSlot 19 for Ad unit Gamasutra//consolepc ### size: [[2,2]]  -->
<div id='div-gpt-ad-welcome'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-welcome');
	}
	);
 </script>
</div>
<!-- End AdSlot 19 -->
	<!-- Beginning Sync AdSlot 20 for Ad unit Gamasutra//consolepc ### size: [[7,7]]  -->
<div id='div-gpt-ad-mi'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-mi');
	}
	);
 </script>
</div>
<!-- End AdSlot 20 -->
    <div class="hide-phone">
                                <!-- Beginning Sync AdSlot 1 for Ad unit Gamasutra//consolepc ### size: [[1,2]]  -->
<div id='div-gpt-ad-skin'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-skin');
	}
	);
 </script>
</div>
<!-- End AdSlot 1 -->
            </div>
	
	<div class="container"> 
	<div class="content-body-wrapper" style="opacity:0;">
	<script src="/prestitial/adblockDetector.js"></script>
	<!-- Google Prestitial Ads start here-->
	<script>
	  
	  var isblocked = "notblocked";
	  if(!document.getElementById('xRokYeIsHL')){
	   isblocked = "blocked";
	  }
	  console.log('lpage==>' + isblocked);
	  if (isblocked == "notblocked") {
		setTimeout(function() {
		console.log('5 second timeout ');
		unhideMainContent();
		}, 5000);
		googletag.pubads().addEventListener('slotRenderEnded', function(event) {
		  if(event.slot.getSlotElementId() == "div-gpt-ad-welcome")
			{
			console.log('interstitial unit found');
			if(event.isEmpty) {
			  console.log('empty Interstitial');
			   unhideMainContent();
			}
			else {
			  console.log('not empty Interstitial');
			}
		  }
		});
		googletag.enableServices();
	  }else{
		  unhideMainContent();
	  }
	function unhideMainContent() {
		console.log('unhide main content');
		var bDiv = document.getElementsByClassName("content-body-wrapper");

		for (var i=0; i<bDiv.length; i++) {
		  if(bDiv[i].style.removeProperty) {
		   bDiv[i].style.removeProperty('opacity');
		  } 
		  else {
			bDiv[i].style.removeAttribute('opacity');
		  }
		}
	}
	
	</script>
	<!-- Google  Prestitial Ads end here-->
	
    <div class="hide-phone">
         <div class="wrapper properties">
            
		
         </div><!--end wrapper-->
    </div>
    
    <br />
     <div class="container bottom3">
     	<div class="span-7">
          	<a href="http://gamasutra.com"><img src="https://twimgs.com/gamasutra/images/gamasutra_logo.png" alt="Gamasutra: The Art &amp; Business of Making Games" width="243" height="77" border="0" /></a><img alt="spacer" src="https://twimgs.com/gamasutra/images/spacer.gif" width="27" />
		</div>
          <div class="hide-phone">
              <div class="div span-16 last leaderboard">
                     
                                                                               <!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra//consolepc ### size: [[728,90]]  -->
<div id='div-gpt-ad-top'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-top');
	}
	);
 </script>
</div>
<!-- End AdSlot 2 -->
                                           
    
              </div>
          </div>
    </div>

		<div class="span-20">
			<div class="show-phone clearfix" style="padding:0px 0 5px 0"><!--sadie change-->
                        <div class="span-5 center ">
								<!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra//consolepc ### size: [[300,50]]  -->
<div id='div-gpt-ad-mobile_leaderboard'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-mobile_leaderboard');
	}
	);
 </script>
</div>
<!-- End AdSlot 2 -->

                        </div>
				</div>

                    <div class="show-phone"><!--there is another on the page for the regular size, this is phone only-->
                         <div class="span-5 last nav_search">
                              <div class="content center">
                                   <span class="nav_searchtxt">SEARCH</span>
                                   <form class="left" name="topsearchph" action="/search/" method="GET">
          
                                               <input name="search_text" type="text" size="25" class="search" />	  
                                              <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearchph.submit(); return false;">GO</a></span>
                                   
                                   </form>
                              </div>
                         </div>
                    </div><!--end show phone-->
                    
                    <div class="show-phone"><!--sadie change-->
                        <div class="span-3">
                                  <div class="login_phone" id="login_phone">
                                       
                                   </div>
                        </div>
                    </div><!--end showphone-->
                    <div class="nav">
                	<div class="span-3 nav_jobs">
                    	<div class="content">
                              <a href="http://jobs.gamasutra.com/">GAME JOBS</a>
                          </div>
                    </div>
                    <div class="span-12 nav_links">
                         <div class="content">
                                   <a href="/updates/">updates</a>
                                   <a href="/blogs/">Blogs</a>
                                   
                                   <a href="/contractors/contractor_display.php">contractors</a>
                                   <a href="/newsletter-signup">newsletter</a>
                                   <a target="_blank" href="https://www.gamecareerguide.com" style="color:#664271;">Game Career Guide</a>
                         </div>
                    </div>
                    <div class="hide-phone">
                        <div class="span-5 last nav_search">
                             <div class="content">
                                  <span class="nav_searchtxt">SEARCH</span>
                                  <form class="left" name="topsearch" action="/search/" method="GET">

                                              <input name="search_text" type="text" size="10" class="search" />	  
                                             <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearch.submit(); return false;">GO</a></span>

                                    </form>
                             </div>
                        </div>
                    </div>
                    <br class="clear">
               </div><!--end nav-->
               <div class="hide-phone"> 
                    <div class="span-20 last"> 
                       <div class="topicmenu">
                            <ul>
                                <li class="activetab"><a href="http://gamasutra.com">ALL</a>
                                </li><li ><a href="/topic/console-pc">CONSOLE/PC</a>
                                </li><li ><a href="/topic/smartphone-tablet">SMARTPHONE/TABLET</a>
                                </li><li ><a href="/topic/indie">INDEPENDENT</a>
                                </li><li ><a href="/topic/vr">VR/AR</a>
                                </li><li ><a href="/topic/social-online">SOCIAL/ONLINE</a>
                                </li></ul>
                                                          <span class="gdmag"><a href="/topic/game-developer"><img src="https://twimgs.com/gamasutra/images/btn_gdmag0.png" width="118px" height="33px"></a></span>
                       </div>
                   </div>
               </div>		
                    <div class="span-20 last content_bg">
                        <div class="hide-phone">
<div class="span-4">
  <div class="content_box_left">
    <div class="leftcol">
        <!--member login-->
                    <table width="166" border="0" cellspacing="0" cellpadding="0">
  <tr>   
    <td id="memberLogin" class="welcome">
    	
    </td>   
  </tr>
</table>                 <!--end memberlogin-->
        
        <!--begin social icons-->
            <!--begin social icons-->
<div  class="bottom2">
    <ul class="leftcol_social">
       <li class="facebook"><a href="http://www.facebook.com/pages/Gamasutra/31610613408" target="_blank">&nbsp;</a></li>
       <li class="twitter"><a href="http://twitter.com/gamasutra" target="_blank">&nbsp;</a></li>
       <li class="feed"><a href="http://gamasutra.com/static2/rssfeeds.html">&nbsp;</a></li>
       <li class="newsletter"><a href="/newsletter-signup">&nbsp;</a></li>
    </ul>
</div>
<!--end social icons-->        <!--end social icons-->
        
        <!--begin page numbers-->
                <!--end page numbers-->
        
        <!--begin leftnav-->
                <div class="leftnav_categories bottom2">
   <a href="/category/programming/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_programming.gif"  width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/programming/">PROGRAMMING</a></div>

   <hr>

   <a href="/category/art/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_art.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/art/">ART</a></div>

   <hr>

   <a href="/category/audio/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_audio.gif" width="24px" height="24px"  /></a>         
   <div class="leftnav_btn"><a href="/category/audio/">AUDIO</a></div>

   <hr>

   <a href="/category/design/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_design.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/design/">DESIGN</a></div>

   <hr>

   <a href="/category/production/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_production.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/production/">PRODUCTION</a></div>

   <hr>
   <a href="/category/business-marketing/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_business.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/business-marketing/">BIZ/MARKETING</a></div>

   <br class="clear">
</div>          <!--end leftnav-->
                  
                    <!-- Beginning Sync AdSlot 3 for Ad unit Gamasutra//consolepc ### size: [[164,59]]  -->
<div id='div-gpt-ad-button1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-button1');
	}
	);
 </script>
</div>
<!-- End AdSlot 3 -->
            <!-- Beginning Sync AdSlot 4 for Ad unit Gamasutra//consolepc ### size: [[164,59]]  -->
<div id='div-gpt-ad-button2'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-button2');
	}
	);
 </script>
</div>
<!-- End AdSlot 4 -->
            <!-- Beginning Sync AdSlot 5 for Ad unit Gamasutra//consolepc ### size: [[164,409]]  -->
<div id='div-gpt-ad-callout'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-callout');
	}
	);
 </script>
</div>
<!-- End AdSlot 5 -->
            <!-- Beginning Sync AdSlot 9 for Ad unit Gamasutra//consolepc ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-custom1');
	}
	);
 </script>
</div>
<!-- End AdSlot 9 -->
            <!-- Beginning Sync AdSlot 11 for Ad unit Gamasutra//consolepc ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom3'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-custom3');
	}
	);
 </script>
</div>
<!-- End AdSlot 11 -->
                
        <!-- begin event tickers -->
			              
        <!-- end event tickers -->
	
         <!--begin jobs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_jobs.png" width="22px" height="20px"/><a href="http://jobs.gamasutra.com/">Latest Jobs</a></div>
<div class="leftnav bottom2">
     <a href="http://jobs.gamasutra.com/"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp;
     <a href="http://feeds.feedburner.com/GamasutraJobs"><strong>RSS</strong></a>
     <hr>
     <strong>June 28, 2019</strong>
     <hr>
     <ul>    
            <li>Square Enix Co., Ltd.<br />
              <a href="https://jobs.gamasutra.com/job/experienced-game-developer-tokyo-31908">Experienced Game Developer</a>
        </li>
        <li class="line"></li>
            <li>Pipeworks, Inc<br />
              <a href="https://jobs.gamasutra.com/job/engineer-iii-serious-games-eugene-oregon-33866">Engineer III - Serious Games</a>
        </li>
        <li class="line"></li>
            <li>Pipeworks, Inc<br />
              <a href="https://jobs.gamasutra.com/job/c-engineer-eugene-oregon-33865">C++ Engineer</a>
        </li>
        <li class="line"></li>
            <li>Cold Iron Studios<br />
              <a href="https://jobs.gamasutra.com/job/back-end-devops-engineer-san-jose-california-33882">Back-End DevOps Engineer</a>
        </li>
        <li class="line"></li>
            <li>Cold Iron Studios<br />
              <a href="https://jobs.gamasutra.com/job/site-reliability-engineer-san-jose-california-33253">Site Reliability Engineer</a>
        </li>
        <li class="line"></li>
            <li>Cold Iron Studios<br />
              <a href="https://jobs.gamasutra.com/job/infrastructure-engineer-san-jose-california-32691">Infrastructure Engineer</a>
        </li>
        <li class="line"></li>
         </ul>    
</div>
         <!--end jobs-->   
           			
         <!--begin blogs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/><a href="/blogs/">Latest Blogs</a></div>
<div class="leftnav bottom2">
    <a href="/blogs/"><strong>View All</strong></a> 
    &nbsp;&nbsp;&nbsp; <a href="/blogs/edit/"><strong>Post</strong></a>
    &nbsp;&nbsp;&nbsp; <a href="/blogs/rss/"><strong>RSS</strong></a>
    <hr>
    <strong>June 28, 2019</strong>
    <hr>   
    <ul>
        
        <li>
            <a href="/blogs/SvyatoslavCherkasov/20190627/345688/Porting_Graveyard_Keeper_to_consoles_and_mobiles.php">Porting Graveyard Keeper to consoles and mobiles</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/TommyThompson/20190626/344877/How_Rare_Automates_Testing_for_AI_and_More_in_Sea_of_Thieves_Part_4_of_4.php">How Rare Automates Testing for AI (and More) in Sea of Thieves (Part 4 of 4)</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/StanislavCostiuc/20190625/345414/Charting_Through_Pacing_of_Uncharted_2_Part_1__Pacing_Principles.php">Charting Through Pacing of Uncharted 2. Part 1 - Pacing Principles</a>
             
                [<a title="4 comments" href="/blogs/StanislavCostiuc/20190625/345414/Charting_Through_Pacing_of_Uncharted_2_Part_1__Pacing_Principles.php#comments">4</a>]
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/SimonCarless/20190622/345347/Video_Game_Deep_Cuts_My_Friend_Pedros_Elite_Beat_Agent.php">Video Game Deep Cuts: My Friend Pedro's Elite Beat Agent</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/BobWhitaker/20190621/345249/Archaeologist_considers_Heavens_Vault.php">Archaeologist considers Heaven's Vault</a>
                    </li>
        <li class="line"></li>
       
    </ul>
</div>
         <!--end blogs-->
         
         <!--begin press releases-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/>Press Releases</div>
<div class="leftnav bottom2">
    <strong>June 28, 2019</strong>
	<hr>
	       <a href="/pressreleases_index.php"><strong>Games Press</strong></a>
   <hr>
   <ul>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/345743/The_RealTime_Action_Chess_MINImax_Tinyverse_Now_on_iPad.php">The Real-Time Action<br />
Chess MINImax Tinyverse<br />
Now...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/345724/Hyper_Light_Drifter_at_120_fps_a_new_way_to_play.php">Hyper Light Drifter at<br />
120 fps, a new way to<br />
play!</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/345725/TOUR_DE_FRANCE_2019_AND_PRO_CYCLING_MANAGER_2019nbspNOW_AVAILABLE.php">TOUR DE FRANCE 2019 AND<br />
PRO CYCLING MANAGER<br />
2019...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/345704/First_Realworld_Harry_Potter_Wizards_Unite_Fan_Festival_Brings_the_Magic_to_Indianapolis_on_Labor_Day_Weekend_2019_nbsp.php">First Real-world Harry<br />
Potter: Wizards Unite<br />
Fan...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/345705/Locality_Update_Live_Now.php">Locality Update Live Now</a>
        </li>
        <li class="line"></li>
         </ul>
   <a href="/pressreleases_index.php"><strong>View All</strong></a> 
   &nbsp;&nbsp;&nbsp; <a href="/pressreleases/rss/"><strong>RSS</strong></a>
</div>         <!--end press releases-->
                         
         <!--begin calendar-->
            <!--

<div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_calendar.png" width="22px" height="20px"/><a href="http://gamasutra.com/calendar/calendar.php">Calendar</a></div>
<div class="leftnav bottom2">
    <a href="http://gamasutra.com/calendar/calendar.php"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp; <a href="http://gamasutra.com/calendar/calendar_submit.php"><strong>Submit Event</strong></a>
    <hr>
    <ul>
        
    </ul>
</div>

-->         <!--end calendar-->
                         
         <!--begin about-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="/contactus">About</a></div>
<div class="leftnav bottom2">
    <ul>
            <li><strong>Editor-In-Chief: </strong><br /><a href="/cdn-cgi/l/email-protection#9ef5f9ecfff8eadef9fff3ffedebeaecffb0fdf1f3">Kris Graft</a></li>
            <li class="line"></li>
         
       
            <li><strong> Editor: </strong><br /> <a href="/cdn-cgi/l/email-protection#d5b4b9b0adfba2b4a2a7ba95a0b7b8fbb6bab8">Alex Wawro</a></li>
			<li class="line"></li>
            
			<li><strong>News Editor: </strong><br /> <a href="/cdn-cgi/l/email-protection#1574797c6666743b787674797a7a7b556077783b767a78">Alissa McAloon</a></li>
            <li class="line"></li>
            
            <li><strong>Contributors: </strong><br />
				Chris Kerr<br />
				Bryant Francis<br />
				Katherine Cross<br />
            <li><strong>Advertising: </strong><br /><a href="/cdn-cgi/l/email-protection#ec9f8d80899fac8b8d818d9f99989e8dc28f8381d39f998e86898f98d1be899d99899f98c9dedca5828a83d6c9dedcab8d818d9f99989e8d"><span class="__cf_email__" data-cfemail="b0c3d1dcd5c3f0d7d1ddd1c3c5c4c2d19ed3dfdd">[email&#160;protected]</span></a></li>
    </ul>
    <hr>
    <div class="center"><a href="/contactus">Contact Gamasutra</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#bfcccacfcfd0cdcbffd8ded2decccacbcdde91dcd0d2">Report a Problem</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#3f515a484c7f585e525e4c4a4b4d5e115c5052">Submit News</a></div>
    <hr>
    <div class="center"><a href="/static2/comment_guidelines.html">Comment Guidelines</a></div>
    <hr>
    <div class="center"><a href="/static2/blogsubmissions.html">Blogging Guidelines</a></div>
    <hr>
    <div class="center"><a href="/static2/howwework.html">How We Work</a></div>
	<!--<hr>
	<div class="center"><a href="/advertise">Advertise with Gamasutra</a></div>-->
    <hr>
    <div class="center"><a href="http://reg.gdconf.com/gama19-media-kit">Download Media Kit</a></div>
</div>

<div class="bottom2">
    <a href="/advertise">
        <img src="https://twimgs.com/gamasutra/images/AdwGama_177x60_button_v1.jpg" alt="Sponsor" border="0" class="whiteTop"  width="177px" height="60px"/>
    </a>
</div>
             <!--end about-->
         
         <!--begin network-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="#">Gama Network</a></div>
<div class="leftnav_network bottom2">
    If you enjoy reading this site, you might also want to check out these UBM Tech sites:
    <hr>
    <a href="http://www.gamecareerguide.com"><!-- img src="http://www.indiegames.com/blog/gcgmini.jpg" align="left" hspace="2"/ --></a> 
    <div class="leftnav_btn"><a href="http://www.gamecareerguide.com">Game Career Guide</a></div>
    <hr>
    <a href="http://www.indiegames.com/blog"><!-- img src="http://www.indiegames.com/blog/indiemini.jpg" align="left" hspace="2"/ --></a>
    <div class="leftnav_btn"><a href="http://www.indiegames.com/blog">Indie Games</a></div>
    <br class="clear">
</div>         <!--end network-->
         
         <!--begin store-->
                     <!--end store-->
         
                
    </div><!--end leftcol-->
  </div>
</div> 
</div>  	<style>.content_box_middle pre {
		overflow-x:auto;
	}
	.item_title{
		    margin-top: 0px !important;
			margin-bottom: 0px !important;
	}
	</style>
<div class="span-16 last">
    <div class="content_box_middle">
        <!-- InstanceBeginEditable name="BodyContent" --> 
        <div class="header_large">
            <span class="left"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png"/><a href="/blogs/">Blogs</a></span>
        </div>
        <div class="page_item"> 
                        <div class="clear">&nbsp;</div>
            <h1 class="item_title">Porting Graveyard Keeper to consoles and mobiles</h1>
            <div>
                <span class="newsAuth">by <a href="/blogs/author/SvyatoslavCherkasov/914979/">Svyatoslav Cherkasov</a> on 06/27/19 10:40:00 am 
                    &nbsp; <img valign="bottom" border="0" src="https://twimgs.com/gamasutra/images/expertIcon_gamaBlog.gif" alt="Expert Blogs" />                    &nbsp; <img valign="bottom" border="0" src="https://twimgs.com/gamasutra/images/featuredIcon_gamaBlog.gif" alt="Featured Blogs" />                                        <br />
                </span>
            </div>
            <div>
                <br>
                                    <span class="comment_text">
                                                    <a href="#comments">Post A Comment</a>
                                            </span>
                    <a name="twitter_share" type="button" href="http://twitter.com?status=RT @gamasutra: Porting Graveyard Keeper to consoles and mobiles http://www.gamasutra.com/blogs/SvyatoslavCherkasov/20190627/345688/" target="_blank"><img src="https://twimgs.com/gamasutra/images/twitter.gif" alt="Share on Twitter" border="0" height="20"/></a>
                    <iframe src="https://www.facebook.com/plugins/share_button.php?href=https://www.gamasutra.com/blogs/SvyatoslavCherkasov/20190627/345688/&layout=button&size=large&mobile_iframe=true&width=72&height=28&appId" width="72" height="28" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>

                    <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
                    <g:plusone size="medium" count="false"></g:plusone>
					<span id="edit_post_link"></span>&nbsp;&nbsp;
					<a href="/blogs/rss/"><img src="https://twimgs.com/gamasutra/images/icon_rss.gif" width="15" height="15" border="0" alt="RSS" /></a>
                            </div>
            <hr>
            <div class="item_body mobile_image_transform">       
                <strong><i><small>
                    The following blog post, unless otherwise noted, was written by a member of Gamasutra&#146;s community.<br />
					The thoughts and opinions expressed are those of the writer and not Gamasutra or its parent company.                </small></i></strong>
                <hr>
                <div class="clear">&nbsp;</div>
                <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><p>In this article, I want to talk about our experience of porting our game &ldquo;Graveyard Keeper&rdquo; to mobiles and consoles.</p>

<p><meta charset="utf-8"></p>

<p>Some basic information: <a href="http://lazybeargames.com/game/graveyard-keeper/">Graveyard Keeper</a> was developed by our team (Lazy Bear Games) in Unity and then ported to XBox One / PS4 / Nintendo Switch by our publisher, tinyBuild. The mobile ports (iOS and Android) were made in-house, by us. Also, a few months after the initial game release, we made a DLC &ldquo;Breaking Dead&rdquo; which was also ported to all platforms. In addition to this, the game was constantly being patched and improved.</p>

<p>As you can see, the setup containing two dev teams is not an easy one. Mix it up with the project in the phase of dynamic development that needs to be deeply optimized for some platforms and you&rsquo;ll get a pretty challenging process.</p>

<p dir="ltr"><img height="619" src="https://lh3.googleusercontent.com/85d3PU3Qg4-ISnLGwoJtoN9qgtQD2VNyVB2rzv8OSigpzGaE3LXAswsox5z7en79VPPwj0bTNHjADF9_PqBo_2ktdpg63L5SVkkEGWO-vONFlhyZn0BjdpUud7bKfWP4X9_ow1pw" width="540"></p>

<p>&nbsp;</p>

<h2 dir="ltr">Time to get technical.</h2>

<p dir="ltr">Looking at our game you can probably think that it is a simple game to port, as it is 2D with pixel art. And if consoles are powerful enough to process 4K/60fps, the pixel 2D graphics wouldn&rsquo;t be a problem. Theoretically, that&rsquo;s true. But practically we used a lot of very complex solutions that were not optimized for consoles and totally unoptimized for mobiles.</p>

<h3>Think of HDD speed.</h3>

<p>You probably heard that the current gen consoles architecture is very similar to the PC. That&rsquo;s true, but technically the hardware differs from the PC. First of all, Xbox One and PS4 use hard disk drives while most of modern PCs use SSD or hybrid drives. So, you have to keep in mind the loading times.</p>

<p>Imagine our surprise, when the first build was loading for during almost 5 minutes.</p>

<p>So, we had to rethink the whole loading and asset storage systems. For example, we began storing not the whole game objects on the scene, but only the information about them in simple (fake) objects. And after the loading is complete we started replacing these fake objects with the real ones on the fly.</p>

<h3>Think of multi-core.</h3>

<p>Also, in our experience writing for the consoles requires using all CPU cores at maximum making the code to work in parallel. By default, Unity games are very dependent on a single core performance. And running the game &ldquo;as is&rdquo; could give you very sensitive performance bottleneck when all other cores are idle while the only single core is under load.</p>

<p>&nbsp;</p>

<p dir="ltr"><img height="560" src="https://lh6.googleusercontent.com/ONKUhdfrIU5NQIezYhq72TsP3p0EgWO2bXZV_qILT2x5H9fIV-1LPSSG-4qCqjtWidz7TTTDRet5OqLdz8GXG3LolHnG2ospIbUlQr2B_MID9ZUaU6Ta5d-LTE7QLMz3CS2BLpvX" width="498"></p>

<p>&nbsp;</p>

<p dir="ltr">We had to move different math and calculations to a different thread running in a parallel to free as much core-#1 power as we can. Basically, that&rsquo;s a good point to keep in mind if you&rsquo;re not planning to port to consoles also as it will give you a better performance anyway.</p>

<p>So, next time we will plan everything we can to run in a separate thread/job. Luckily, Unity had improved multi-threading a lot during the last year implementing job system and ECS.</p>

<h3>Think of graphics optimization (even for 2D games!).</h3>

<p>Another heavy issue for us was the graphics. We had no previous experience optimizing anything for consoles or mobiles. Therefore we were OK to make a tree combined of 20 separate sprites just to make it easier to design. There was no need for such amount of sprites for a single tree in the game itself.</p>

<p>&nbsp;</p>

<p dir="ltr"><img height="443" src="https://lh6.googleusercontent.com/BO7MHqOwlksiN0aGwsE2C1lEk_iO3utLTDgBJ5ZAzXkzcZiGIrYZWOIDyTKmucT5PltXwKiBYO7WnpcONSRtMsf2piPoEWB323ztbGgupyOPOzgQ64TzxWPaSV0GryzRJMcWnw57" width="602"></p>

<p>Of course, we needed to merge sprites to reduce the amount of layers. You can see the amount of initial geometry on the scene here:</p>

<p><img height="305" src="https://lh3.googleusercontent.com/OPbYhmFR5J3RWvWXmekP9vXVmV6ggeVzJrS4YSSiQoPYkkrsrw9GFiAtbMg8b7ool3nmZDjPTeT6Hq0C8rVtUnCpMdUNYrZYxbZ8U-fhzctGrIwbDAz2czMDpPTSKy61JcWUS_Oa" width="602"></p>

<p>The rightmost picture shows the &ldquo;overdraw amount&rdquo;. That means each time one sprite is drawn over another, the color on that picture becomes brighter. So, you can see that despite the simplicity of the look, there are really a lot of polygons drawn over each other.</p>

<p>Also, all sprites of the game are lit by a complex shader that not only uses the normal-maps, but calculates the pseudo 3D-depth of the picture.</p>

<p dir="ltr"><img height="355" src="https://lh5.googleusercontent.com/ubPwq11ZdGSMFONnPaShbDM-goMBU4JNwuAYt5p8S5KmeXp674Ke7z77Bq887wSjbd2eb9n36kN9XCqGWyiflU_KeR8C6SFLTgJedGzNIYGr7OPU3uziOd2x3estQYubA66rR9kg" width="348"></p>

<p>We had to make different versions of visual optimization for different platforms. For example, we had to completely change the lighting shader and its behavior for mobiles.</p>

<h3 dir="ltr">Think of platform-specific issues.</h3>

<p>Also, there is a lot of platform-specific work (especially for consoles). For example, you not only need to support the gamepad, but need to deal with different uncommon situations like when a user plays the game, the gamepad turns off, user connects another controller and logs in to a different profile. And that&rsquo;s in the middle of the game. There are different large lists of such cases that your game needs to deal with.</p>

<p>Another issue you have to think about is the saving system. Your game had to work with asynchronous saving routines and treat any file corruption could happen.</p>

<h2 dir="ltr">Patches and DLCs.</h2>

<p dir="ltr">As mentioned above, we worked with an external porting team on the side of our publisher and pushing all new content, fixes and patches became a difficult task. You need to plan everything ahead. You can&rsquo;t just tell the guys to push your last fix to Xbox if they are making a Switch port and everybody is busy with that.&nbsp;</p>

<p>And keeping in mind that we&rsquo;re a small team that likes to develop games with a high passion, that doesn&rsquo;t go well with planning ahead. That&rsquo;s the reason we couldn&rsquo;t easily port the first &ldquo;Breaking Dead&rdquo; DLC to the Xbox. We didn&rsquo;t plan it very well. One day we just woke up and decided to make zombies and put them in the first DLC. But guys at tinyBuild were busy deeply optimizing and porting the game to Nintendo Switch. They couldn&rsquo;t drop that process and begin to port this DLC right away. They needed to finish their port first.</p>

<p>That was the downside of the idea of making a simultaneous release on PC and Xbox. Ideally we should release a PC build, fix all bugs were found and only then start porting it to consoles -- or spend months in isolated QA beforehand, without real player feedback. And only after the port is done, start making a DLC. But we couldn&rsquo;t afford spending so much time on that. We had to do everything right away.</p>

<p>&nbsp;</p>

<p dir="ltr"><img height="283" src="https://lh5.googleusercontent.com/FssCUBUONuGqTzJUqxDj2sT16sDyjr7r03smfO1NJjIHuGMO4TpCbThMTQ8RJTnFEJAvPJFHOJNgqiCrhMKnR7aq6LsneFmLKeZ-dz3JW5IqN2mX8Qwn85Pjy3aqoPIxObgFoY06" width="602"></p>

<p>&nbsp;</p>

<p dir="ltr">That&rsquo;s the reason we couldn&rsquo;t release the first Breaking Dead DLC for free on other platforms (as it was on the PC). When you develop on multiple platforms, the costs and timelines ramp up pretty quickly. Even porting and releasing a patch eats up a lot of resources.</p>

<p>Releasing titles, DLCs and updates always require passing platform compliance requirements, which means certification by platform holders. The more complicated your game mechanics and the bigger the amount of the APIs you are using the more requirements you will need to surpass. This means that you need to test your content against these requirements before submitting it for certification to make sure that the chances of passing it are good. Otherwise you may encounter a big list of issues to fix and might not pass it (probably you just won&rsquo;t) within first submission. Additional submissions might also lead to additional costs. But the most risky thing about not passing the certification in time is delaying the announced release dates.&nbsp;</p>

<p>This is extremely difficult with fast iteration cycles we had on PC. It would be impossible to real-time merge new content into the console builds, as shown in the diagram in the beginning of the article. Having in-house resources will require at least one programmer dedicated to each platform and a proficient QA team that is constantly testing the title being ported and report the issues that fail the requirements so the porting developers can fix them before being found by the certification team on the platform holder side. It requires building the whole porting structure within the studio. And this is not only the resources, but the specific knowledge and skill set involved in it.</p>

<p dir="ltr">Long story short it&rsquo;s very easy to release DLC on PC and keep on iterating on it in real time, while launching the same content on consoles adds a lot of overhead costs and complexity to the whole process.&nbsp;</p>

<p dir="ltr"><img height="360" src="https://lh6.googleusercontent.com/6iS1J6yHKV5iz5qK7PYPrZB_1GF4y24G1H-b87pIPi3MOxZNCqAzN4_wwgpq6SVocAPWeUsJSSahx-I-dFVRRbHFZHAAvmiWThUNx6AJS_QkciZJh-pv5DVNdy1jaTCOyLpV7RJL" width="303"></p>

<p dir="ltr"><em>Sviatoslav Cherkasov<br>
lead programmer<br>
at <a href="http://lazybeargames.com">Lazy Bear Games</a></em></p></body></html>

            </div>   
                                                <hr>
                    <div class="hide-phone">
                        <h3>Related Jobs</h3>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/experienced-game-developer-tokyo-31908"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/944567.jpg" alt="Square Enix Co., Ltd." width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Square Enix Co., Ltd. &mdash; 
                                                                          Tokyo,
                                                                                                            Japan
                                    <br />
                                    [06.27.19]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/experienced-game-developer-tokyo-31908">Experienced Game Developer</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/engineer-iii-serious-games-eugene-oregon-33866"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1029687.png" alt="Pipeworks, Inc" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Pipeworks, Inc &mdash; 
                                                                          Eugene,
                                                                                                              Oregon,
                                                                        United States
                                    <br />
                                    [06.27.19]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/engineer-iii-serious-games-eugene-oregon-33866">Engineer III - Serious Games</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/c-engineer-eugene-oregon-33865"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1029687.png" alt="Pipeworks, Inc" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Pipeworks, Inc &mdash; 
                                                                          Eugene,
                                                                                                              Oregon,
                                                                        United States
                                    <br />
                                    [06.27.19]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/c-engineer-eugene-oregon-33865">C++ Engineer</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/back-end-devops-engineer-san-jose-california-33882"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1022226.gif" alt="Cold Iron Studios" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Cold Iron Studios &mdash; 
                                                                          San Jose,
                                                                                                              California,
                                                                        United States
                                    <br />
                                    [06.27.19]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/back-end-devops-engineer-san-jose-california-33882">Back-End DevOps Engineer</a>
                                </div>
                           </div>
                                            </div>
                    <br class="clear"/><br/>
                    <div class="right small">
                        <strong>[<a href="http://jobs.gamasutra.com/">View All Jobs</a>]</strong>
                    </div>
                    <br class="clear"/><br/>
                                        <hr>
            							<script type='text/javascript'>
																
								//Rectangle 1 on small mobile device
								if (document.documentElement.clientWidth <= 767)
								{ document.write('<div id="div-gpt-ad-rec1"><center>'); 
										googletag.cmd.push(function(){
											googletag.display('div-gpt-ad-rec1'); 
										});
										document.write('</center></div>'); }
								
							</script>


                <div id="dynamiccomments">
					<span id="cmtArticleId" style="display:none">345688</span>
					<span id="cmtStory_type" style="display:none">blog</span>
					<span id="cmtArticleUri" style="display:none">/blogs/SvyatoslavCherkasov/20190627/345688/Porting_Graveyard_Keeper_to_consoles_and_mobiles.php?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+GamasutraFeatureArticles+%28Gamasutra+Feature+Articles%29</span>
					<span id="author_id" style="display:none">914979</span>
					<span id="author_user_id" style="display:none">33528593</span>
                    <a style="font-weight: bold; font-size: 16px;" name="comments"> Loading Comments</a>
                    <br />
                    <hr noshade size="1" class="hr_comment">
                
                    <div align="center">
                         <img style="padding-top: 2px; padding-right: 5px; padding-bottom: 5px;" alt="loader image" src="/ajax-loader.gif"/>
                    </div>
       
                </div>
                    </div>  
        <!-- InstanceEndEditable -->
    </div><!--end contentbox-->
</div><!--end span-16-->

            </div>
            <br class="clear">
	</div><!--end span-21-->

        <!--begin right sidebar-->
     	<div class="hide-phone center">
               <div class="span-4 last">
                   <!--right hand ads start here-->

  
                            <!-- Beginning Sync AdSlot 7 for Ad unit Gamasutra//consolepc ### size: [[160,600]]  -->
<div id='div-gpt-ad-sky1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-sky1');
	}
	);
 </script>
</div>
<!-- End AdSlot 7 -->
        <!-- Beginning Sync AdSlot 8 for Ad unit Gamasutra//consolepc ### size: [[160,160]]  -->
<div id='div-gpt-ad-Ltile1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-Ltile1');
	}
	);
 </script>
</div>
<!-- End AdSlot 8 -->
      
		 
               	</div>
                 </div>
     <!--end right sidebar-->         
        <!-- </div> Extra Div -->
					<!-- Beginning Sync AdSlot 21 for Ad unit Gamasutra//consolepc ### size: [[8,2]]  -->
<div id='div-gpt-ad-native'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-native');
	}
	);
 </script>
</div>
<!-- End AdSlot 21 -->
			<!-- Beginning Sync AdSlot 22 for Ad unit Gamasutra//consolepc ### size: [[8,4]]  -->
<div id='div-gpt-ad-insight'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-insight');
	}
	);
 </script>
</div>
<!-- End AdSlot 22 -->
			<!-- Beginning Sync AdSlot 23 for Ad unit Gamasutra//consolepc ### size: [[4,4]]  -->
<div id='div-gpt-ad-video'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-video');
	}
	);
 </script>
</div>
<!-- End AdSlot 23 -->
				
     
     <br class="clear">
<link rel="stylesheet" type="text/css" href="https://twimgs.com/informationweek/footernav/jan2015/css/superfooter_dark.css" />
<div align="center">
          <!-- Beginning Sync AdSlot 6 for Ad unit Gamasutra//consolepc ### size: [[3,3]]  -->
<div id='div-gpt-ad-ribbon'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-ribbon');
	}
	);
 </script>
</div>
<!-- End AdSlot 6 -->
</div>
<!--begin footer-->
<!-- BEGIN DARK FOOTER -->
<div align="center">
  <div class="superfooter" id="footerblack">
    <div class="superfooter container" id="pagecenter">
    <div id="top" style="max-height: 146px !important;">
    <!--DARK FOOTER LEFT SIDE -->
    <div  id="left">
    <!--<a href="http://www.ubmtechweb.com/" target="_blank"><img src="https://twimgs.com/nojitter/gama/UBM_Logo_White.png" width="88" height="111" border="0" alt="UBM"></a>-->
    <a href="https://informatech.com" target="_blank"><img src="https://twimgs.com/nojitter/gama/Informa_Tech_Logo.png" width="88" height="95" border="0" alt="UBM"></a>
    </div><!-- / DARK FOOTER LEFT SIDE -->
    <!-- DARK FOOTER rightlinks SIDE -->
    <div class="superfooter" id="rightlinks">
      <div class="list-div" id="tech-brands">
        <ul class="first-list">
          <li class="footer_title">TECHNOLOGY GROUP</li> 
          <li><a href="http://www.blackhat.com/" target="_blank">Black Hat</a></li>
<li><a target="_blank" href="http://contentmarketinginstitute.com/">Content Marketing Institute</a></li>
<li><a target="_blank" href="http://www.contentmarketingworld.com/">Content Marketing World</a></li>
          <li><a href="http://www.darkreading.com/" target="_blank">Dark Reading</a></li> 
         
        </ul>
        <ul>
          <li><a target="_blank" href="http://www.enterpriseconnect.com/">Enterprise Connect</a></li>
          <li><a href="http://www.gdconf.com/" target="_blank">GDC</a></li>
          <li><a href="/" target="_blank">Gamasutra</a></li>
		  <li><a href="http://www.thinkhdi.com/" target="_blank">HDI</a></li>
        </ul>
        <ul>
          <li><a href="http://www.icmi.com/" target="_blank">ICMI</a></li>
          <li><a href="http://www.informationweek.com/" target="_blank">InformationWeek</a></li>
	 <!--  <li><a href="http://insecurity.com/" target="_blank">INsecurity</a></li> -->
	 <li><a href="http://www.interop.com" target="_blank">Interop</a></li>
	 <li><a href="http://www.networkcomputing.com/" target="_blank">Network Computing</a></li>
        </ul>
        <ul class="last-list">
	          <li><a href="http://www.nojitter.com/" target="_blank">No Jitter</a></li>
		  <li><a href="http://www.smworld.com/" target="_blank">Service Management World</a></li>
		  <li><a href="http://www.vrdconf.com/" target="_blank">VRDC</a></li>
        </ul>
      </div>
      <div class="list-div" id="communities-served">
         <ul class="first-list">
	  <li class="footer_title">COMMUNITIES SERVED</li>
	  <li><a target="_blank" href="https://tech.ubm.com/content-marketing">Content Marketing</a></li>
	  <li><a href="https://tech.ubm.com/enterprise-it" target="_blank">Enterprise IT</a></li>
	  <li><a href="https://tech.ubm.com/enterprise-communications" target="_blank">Enterprise Communications</a></li>
	  <li><a href="https://tech.ubm.com/game-and-vr-development" target="_blank">Game & VR Development</a></li>
	  <li><a href="https://tech.ubm.com/information-security" target="_blank">Information Security</a></li>
	  <li><a href="https://tech.ubm.com/it-servicessupport-and-contact-center" target="_blank">IT Services & Support/<br/>Contact Center</a></li>
	</ul>
      </div>
      <div class="list-div" id="working-with-us">
        <ul class="first-list">
	  <li class="footer_title">WORKING WITH US</li>
	  <li><a href="https://tech.ubm.com/contact-us" target="_blank">Advertising Contacts</a></li>
	  <li><a href="https://tech.ubm.com/event-calendar" target="_blank">Event Calendar</a></li>
	  <li><a href="https://tech.ubm.com/" target="_blank">Tech Marketing Solutions</a></li>
	  <li><a href=" http://tech.ubm.com/contact-us/" target="_blank">Contact Us</a></li>
	  <li><a href="http://wrightsmedia.com/sites/ubm/index.cfm" target="_blank">Licensing</a></li>
	</ul>
      </div>
    </div><!-- / DARK FOOTER rightlinks -->
  </div><!--end top-->
    <div style="clear:both;"></div><!-- // to clear the right and left evenly // -->
  <div  id="bottom">
    <ul class="blue">
      <li><a href="http://legal.us.ubm.com/terms-of-service/" target="_blank" class="blue">Terms of Service</a></li>
      <li><a href="http://legal.us.ubm.com/privacy-policy/" target="_blank" class="blue">Privacy Statement</a></li>
  <li><a href="http://reg.ubmamevents.com/UBMLegalEntities" target="_blank" class="blue">Legal Entities</a></li> 
      <li>Copyright &#169; 2019 UBM, All rights reserved</li>
    </ul>
  </div>
    </div>
  </div><!-- / END footergrey -->
</div><!-- / END align="center" -->
<!-- / END DARK FOOTER -->

</div><!--end content-body-wrapper-->
     </div><!--end container-->

<!-- Eloqua tracking code -->
<SCRIPT TYPE='text/javascript' LANGUAGE='JavaScript' SRC='https://twimgs.com/nojitter/gama/js/elqtracking.js'></SCRIPT>
<SCRIPT TYPE='text/javascript' LANGUAGE='JavaScript' SRC='https://twimgs.com/informationweek/elqNow/elqCfg.js'></SCRIPT><SCRIPT TYPE='text/javascript' LANGUAGE='JavaScript' SRC='https://twimgs.com/informationweek/elqNow/elqImg.js'></SCRIPT>
<!-- End Eloqua tracking code -->

<script type="text/javascript" src="https://ins.techweb.com/beacon/js/beacon-min.js"></script>
<script type="text/javascript">
var beacon = new UBM.Beacon({environment: 'p', apiKey: '31fa8154ead6bb6b2bcefa32b0b2bd86ef990485d4def29a6117223512da2973'});
beacon.pageview();
</script>
<script type="text/javascript">
	var registerData='';
	registerCheck();
	function registerCheck(){
		$.ajax({
			url: '/omnloginstatus.php',
			async : false,
			success: function(result){
				registerData = result.replace('"','');
				registerData = registerData.replace('"','');
			}
		});
	}
</script>

<script type="text/javascript" src="https://twimgs.com/gamasutra/js/combined.js"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/nextgengama.js?v5"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/checkauth.js?v2"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/oasTrack_v1.js"></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<!-- SiteCatalyst code version: H.21.
Copyright 1996-2010 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->


<script language="JavaScript" type="text/javascript" src="https://epromos.ubmcanon.com/s_code/ubm-tech-global-app-measurement.js?ddd"></script>
<script language="JavaScript" type="text/javascript"><!--
    /* You may give each page an identifying name, server, and channel on
    the next lines. */
	s.pageName="";
	s.server="";
	s.channel="";
	s.pageType="";
	s.prop1="";
	s.prop2="345688";
	s.prop3="Gamasustra | 345688 | Porting Graveyard Keeper to consoles and mobiles";
	s.prop4="Porting Graveyard Keeper to consoles and mobiles";
	s.prop5="GAMASUTRA BLOG";
	s.prop6="";
	s.prop7="Svyatoslav Cherkasov";
	s.prop8="userAgent";
	s.prop9="";
	s.prop10="";
	s.prop13="";
    s.prop19=registerData;
	s.contextData['Newsletter_signup'] ="";
	/* Conversion Variables */
	s.campaign="";
	s.state="";
	s.zip="";
	s.events="event5";
	s.products="";
	s.purchaseID="";
	s.eVar1="programming,production,console-pc,serious,indie,smartphone-tablet";
	s.eVar2="";
	s.eVar3="";
	s.eVar4="";
	s.eVar5="";
	/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
    var s_code = s.t(); if (s_code) document.write(s_code)//--></script>
<script language="JavaScript" type="text/javascript"><!--
    if (navigator.appVersion.indexOf('MSIE') >= 0) document.write(unescape('%3C') + '\!-' + '-')
//--></script><noscript><a href="http://www.omniture.com" title="Web Analytics"><img
src="http://cmp.112.2o7.net/b/ss/cmpglobalvista/1/H.21--NS/0"
height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.21. -->          
  
<!-- Begin ADSNATIVE Code -->
<script type="text/javascript" src="https://static.adsnative.com/static/js/render.v1.js"></script>
<!-- End ADSNATIVE Code -->  
<!--Begin Ad script for pixel --> 

<script type="text/javascript">
    adroll_adv_id = "AJSB6AWABZB2RFHAOYSOZH";
    adroll_pix_id = "2RTKKW6YFBHIVKRM6FNJ4D";
    /* OPTIONAL: provide email to improve user identification */
    /* adroll_email = "username@example.com"; */
    (function () {
        var _onload = function(){
            if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
            if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
                document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
        };
        if (window.addEventListener) {window.addEventListener('load', _onload, false);}
        else {window.attachEvent('onload', _onload)}
    }());
</script>

<!--END Ad script for pixel -->
</body>
</html>                
                