<!doctype html>
<html lang="en">
<head>	
	        <!-- <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> -->
		<meta http-equiv='Content-Type' content='text/html; charset=UTF-8' /> 
		<title>Gamasutra: Ruben Torres Bonet's Blog - Unity C#: Improved Out Parameters (C# 7.0)</title>
	<meta name="pagecaching" content="309" />
			<meta name="keywords" content="game development, game developer, game programming, game programmer, videogame, artificial intelligence, 3D animation, game design, 3D modeling, game business, game jobs, game directory, game development software, game technology, 3D technology, game producer, game audio, game animation, virtual reality, digital entertainment, PC game, Xbox game, game news, new game, arcade development, Nintendo development, Playstation development, Playstation 2, PS2, Dreamcast development, Game Developer magazine, Computer Game Developers Conference, Game Developers Conference, Independent Game Developers Conference, CMP Game Media Group, game industry research, online game development, digital assets, free textures, free 3D models, free shaders, Gamasutra Exchange, 3D Studio Max textures" /><meta name="description" content="Today I'm starting a new series of short posts about neat C# features that many Unity game developers are missing on. In this post, you will learn abo" />
		<!--[if lt IE 9]>
		<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->
	<style>
		
			.cke_source{
				white-space:normal !important;
			}
			.hide_phone > iframe {
				width: 100%;
			}
			@media only screen and (max-width:479px){
				.hide_phone > iframe {
					height: auto;
				}
				.embeddedContent iframe, .page_data_1 iframe {
					width: 100%;
				}
			}
			.properties ul li {
				padding: 5px 28px !important;
			}
			.formElement label.questionLabel p.description {
				font-weight: normal;
				padding: 0 !important;
			}
			div#rightlinks ul {
				padding: 0 15px !important;
			}
			.article img {
				max-width: 100% !important;
			}
			@media screen and (max-width: 425px) {
				blockquote{
					float:none !important;
					clear:both;
				}
			}
		

	</style>
	<!-- CSS -->
        
        
<meta property="fb:app_id" content="1424004174373289"/>		
        			 <meta property="og:type" content="article"/>
			 <meta property="og:url"  content="https://gamasutra.com/blogs/RubenTorresBonet/20200330/360305/Unity_C_Improved_Out_Parameters_C_70.php" />
			 <meta property="og:title" content="Unity C#: Improved Out Parameters (C# 7.0)" />
                   	 	
                                <meta name="og:image" content="https://gamasutra.com/blogs/edit/img/portrait/1009721/portrait.jpg" />
                         			 <meta property="og:description" content="Today I'm starting a new series of short posts about neat C# features that many Unity game developers are missing on. In this post, you will learn about the improved Unity C# out Parameters feature that is available since C# 7.0." />
				
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:site" content="@gamasutra" />
		<meta name="twitter:creator" content="@gamasutra" />
					<meta name="twitter:title" content="Unity C#: Improved Out Parameters (C# 7.0)" />
			<meta name="twitter:description" content="Today I'm starting a new series of short posts about neat C# features that many Unity game developers are missing on. In this post, you will learn about the improved Unity C# out Parameters feature that is available since C# 7.0." />
			<meta name="twitter:creator" content="@gamasutra" />
			<meta name="twitter:url" content="https://gamasutra.com/blogs/RubenTorresBonet/20200330/360305/Unity_C_Improved_Out_Parameters_C_70.php" />
			<meta name="twitter:image" content="https://gamasutra.com/blogs/edit/img/portrait/1009721/portrait.jpg" />
		
        
                	<link rel="canonical" href="https://gamasutra.com/blogs/RubenTorresBonet/20200330/360305/Unity_C_Improved_Out_Parameters_C_70.php" />
                <link rel="alternate" type="application/rss+xml" title="Gamasutra Article Feed" href="https://feeds.feedburner.com/GamasutraFeatureArticles/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra News Feed" href="https://feeds.feedburner.com/GamasutraNews/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Columns Feed" href="https://feeds.feedburner.com/GamasutraColumns/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Jobs Feed" href="https://feeds.feedburner.com/GamasutraJobs/" />
        <!-- link href="https://twimgs.com/gamasutra/css/minified.css" rel="stylesheet" type="text/css" / -->
        <link href="https://twimgs.com/nojitter/gama/css/gama_unminified.css?v1" rel="stylesheet" type="text/css" />
		<style>
			
				#div-gpt-ad-Ltile1 {
					margin-top: 10px;
				}
			
		</style>
        
                         <meta name="node" content="Gama1"/>
            
        <meta name="pagecaching" content="570"/>
        		<script language="JavaScript" type="text/javascript" src="https://i.cmpnet.com/s_code/VisitorAPI.js"></script>
        <script type="text/javascript" src="https://i.cmpnet.com/s_code/at.js"></script>
        <script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/redesign_comments.js"></script>
		<script src="//code.jquery.com/jquery-1.8.2.min.js"></script>
		<script type="text/javascript" async src="https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.5/MathJax.js?config=TeX-MML-AM_CHTML"></script>
		<script type="text/javascript"> 
        
		function checkMail(obj){
	 
		   var think_opt_out = document.getElementById('Think_Opt_Out');
	 
		   if (document.getElementById('Think_Opt_Out').checked) {
	 
				 document.getElementById('Think_Opt_In').value = 0;
		   } else {
	 
				 document.getElementById('Think_Opt_In').value = 1;
		   }
		   var firstname = document.getElementById('firstname').value;
		   if (firstname == ""){
				 alert('Please provide your first name');
				 return false;
		   }
	 
		   if (document.getElementById('lastname').value == ''){
				 alert("Please provide your lastt name");
				 return false;
		   }
	 
	 
		   var x = document.getElementById('EmailAddr').value;
	 
		   var filter  = /^([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4})+$/;
		   if (filter.test(x)) { return true; }
		   else  { alert('Invalid Email Address detected. Please correct.'); return false; }
	 
	 
		}
		 
		</script>
        <script type="text/javascript" src="https://twimgs.com/gamasutra/js/md5.js"></script>

        

        <script type="text/javascript">
        var adrand = parseInt(Math.random()*1000000000, 10);
        var adkeys = "key1+key2+key3+key4";
        </script>

        	<!-- Mobile Specific Metas -->
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /> 
	
	<script type="text/javascript">
            
		var browser			= navigator.userAgent;
		var browserRegex	= /(Android|BlackBerry|IEMobile|Nokia|iP(ad|hone|od)|Opera M(obi|ini))/;
		var isMobile		= false;
		if(browser.match(browserRegex)) {
			isMobile			= true;
			
		}
        
	</script>
        <!-- Start Visual Website Optimizer Asynchronous Code -->
        <script type='text/javascript'>
        
        var _vwo_code=(function(){
        var account_id=32069,
        settings_tolerance=2000,
        library_tolerance=2500,
        use_existing_jquery=false,
        // DO NOT EDIT BELOW THIS LINE
        f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
        
        </script>
        <!-- End Visual Website Optimizer Asynchronous Code -->
       
        
        <!-- Start HeatMap.me Code -->
		<script type='text/javascript'>
		(function(h,e,a,t,m,p)
		{ m=e.createElement(a);m.async=!0;m.src=t; p=e.getElementsByTagName(a)[0];p.parentNode.insertBefore(m,p); }
		)(window,document,'script','https://u.heatmap.it/log.js');
		</script>
		<!-- End HeatMap.me Code -->
        
        
				
		<!-- Start: GPT Sync -->
        <script>
		
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.slots = googletag.slots || {};
        var gptadslots=[];
		
        </script>
        <script src="//www.googletagservices.com/tag/js/gpt.js"></script>

        <script type="text/javascript">
              
                      googletag.pubads().setTargeting('kw',['programming','console-pc','serious','indie','social-online','smartphone-tablet','vr']);
                                            googletag.pubads().setTargeting('aid',['360305']);
          		
				if (document.documentElement.clientWidth > 767)
				{
				//Adslot 19 declaration
		
					gptadslots[19]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[2,2]],'div-gpt-ad-welcome').setTargeting('pos',['welcome']).setTargeting('testAd',['']).addService(googletag.pubads());
		
				}
				else
				{
				//Adslot 20 declaration
		
					gptadslots[20]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[7,7]],'div-gpt-ad-mi').setTargeting('pos',['mi']).setTargeting('testAd',['']).addService(googletag.pubads());
		
				}
				  
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		
					gptadslots[1]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[1,2]],'div-gpt-ad-skin').setTargeting('pos',['skin']).setTargeting('testAd',['']).addService(googletag.pubads());

					gptadslots[2]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[728,90]],'div-gpt-ad-top').setTargeting('pos',['top']).setTargeting('testAd',['']).addService(googletag.pubads());
		
				}else{ 
		
					gptadslots[13]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[300,50]],'div-gpt-ad-mobile_leaderboard').setTargeting('pos',['mobile_leaderboard']).setTargeting('testAd',['']).addService(googletag.pubads());
		

		}
		            
          //Adslot 1 declaration
       

				  //Adslot 2 declaration
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 3 declaration
					 gptadslots[3]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,59]],'div-gpt-ad-button1').setTargeting('pos',['button1']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 4 declaration
					 gptadslots[4]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,59]],'div-gpt-ad-button2').setTargeting('pos',['button2']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 5 declaration
					 gptadslots[5]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,409]],'div-gpt-ad-callout').setTargeting('pos',['callout']).setTargeting('testAd',['']).addService(googletag.pubads());
		

				}
		
						
			//Adslot 6 declaration
			gptadslots[6]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[300,250]],'div-gpt-ad-rec1').setTargeting('pos',['rec1']).addService(googletag.pubads());
						
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 7 declaration
					 gptadslots[7]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[160,600]],'div-gpt-ad-sky1').setTargeting('pos',['sky1']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 8 declaration
					 gptadslots[8]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[160,160]],'div-gpt-ad-Ltile1').setTargeting('pos',['Ltile1']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 9 declaration
					 gptadslots[9]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,177]],'div-gpt-ad-custom1').setTargeting('pos',['custom1']).setTargeting('testAd',['']).addService(googletag.pubads());

					
					 //Adslot 11 declaration
					 gptadslots[11]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[164,177]],'div-gpt-ad-custom3').setTargeting('pos',['custom3']).setTargeting('testAd',['']).addService(googletag.pubads());
					  
          
		
		}
		
		 gptadslots[14]= googletag.defineSlot('/2441/Gamasutra/consolepc', [[3,3]],'div-gpt-ad-ribbon').setTargeting('pos',['ribbon']).setTargeting('testAd',['']).addService(googletag.pubads());
		 		 		 													//Adslot 21 declaration
			gptadslots[21]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[8,2]],'div-gpt-ad-native').setTargeting('pos',['native']).setTargeting('testAd',['']).addService(googletag.pubads());
			//Adslot 22 declaration
			gptadslots[22]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[8,4]],'div-gpt-ad-insight').setTargeting('pos',['insight']).setTargeting('testAd',['']).addService(googletag.pubads());
			//Adslot 23 declaration
			gptadslots[23]=googletag.defineSlot('/2441/Gamasutra/consolepc',[[4,4]],'div-gpt-ad-video').setTargeting('pos',['video']).setTargeting('testAd',['']).addService(googletag.pubads());
		

         googletag.pubads().enableSingleRequest();
		 googletag.pubads().collapseEmptyDivs();
         		 googletag.pubads().enableAsyncRendering();
         googletag.enableServices();
        </script>
        <!-- End: GPT -->
	
	<script type="text/javascript">
	
	  var _AdsNativeOpts =
	  {
	
		keywords: ['consolepc']
	
	  };
	
	</script>
        
         		<script type="text/javascript">
 		
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-48094207-1']);
			_gaq.push(['_trackPageview']);
			(function()
			{ var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); }
			)();
		
		</script>
		<link rel="stylesheet" href="https://i.ubm-us.net/oas/nativead/css/game_nativead.css" />
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/nativead.js"></script>
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/game_nativead.js"></script>
			<!-- Twitter universal website tag code -->
		<script>
		
		!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
		},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js',
		a=t.getElementsByTagName(n)[0],a.parentNode.insertBefore(u,a))}(window,document,'script');
		// Insert Twitter Pixel ID and Standard Event data below
		twq('init','nx55r');
		twq('track','PageView');
		
		</script>
		<!-- End Twitter universal website tag code -->
		
		<!-- Facebook Pixel Code -->
		<script>
		
		!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
		n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
		n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
		t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
		document,'script','https://connect.facebook.net/en_US/fbevents.js');
		fbq('init', '832000476880185'); // Insert your pixel ID here.
		fbq('track', 'PageView');
		
		</script>
		<noscript><img height="1" width="1" style="display:none"
		src="https://www.facebook.com/tr?id=832000476880185&ev=PageView&noscript=1"
		/></noscript>
		<!-- DO NOT MODIFY -->
		<!-- End Facebook Pixel Code -->
		<link rel="stylesheet" href="https://twimgs.com/nojitter/gama/css/informa-iribbon.css" />
	<script src="https://twimgs.com/nojitter/gama/js/informa-iribbon.js"></script>
	<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/cookie_banner.js"></script>
	<link rel="stylesheet" href="https://img.deusm.com//darkreading/cookie_banner_css.css" />
	
<!-- Eloqua tracking code -->
<script type='text/javascript' language='JavaScript'>
var _elqQ = _elqQ || [];
_elqQ.push(['elqSetSiteId', '2150']);
_elqQ.push(['elqUseFirstPartyCookie', 'trk.gamasutra.com']);
_elqQ.push(['elqTrackPageView']);

(function () {
function async_load() {
    var s = document.createElement('script'); s.type = 'text/javascript'; s.async = true;
    s.src = '//img.en25.com/i/elqCfg.min.js';
    var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
}
if (window.addEventListener) window.addEventListener('DOMContentLoaded', async_load, false);
else if (window.attachEvent) window.attachEvent('onload', async_load); 
})();
</script>
<!-- End Eloqua tracking code -->	
</head>
<body >
	<!--Cookie banner code starts here -->
	<div id="gdpr_banner" style="display:none;">
	<div id = "cookie">
	<div class="gdpr-popup-border">
	<div class="gdrp-popup-content">
		<div id="popup-text">This site uses cookies to provide you with the best user experience possible. By using Gamasutra, you accept <a href="https://tech.informa.com/cookie-policy" target="_blank">our use of cookies.</a></div>
		<div id="popup-buttons"><span class="close-button" >&times;</span></div>
	</div>
	</div>
	</div>
	</div>
	<!--Cookie banner code ends here -->
	<!-- Informa Branding code goes here-->
	<div id="iribbon-container" class="content-body-wrapper" style="padding-top:10px; opacity:0;">
			<button id="iribbon-title" title="show/hide" class="inactive">Informa</button>
			<div id="iribbon-detail" class="ribbon-hide" style="">
    		<div id="iribbon-left">
        		<p>Gamasutra is part of the Informa Tech Division of Informa PLC</p>
        		<ul>
            		<li class="iribbon-mainlink"><a href="https://informa.com/" tabindex="-1" class='iribbon-opacity-out'>Informa PLC</a></li>
            		<li><a href="https://informa.com/About-Us/" tabindex="-1" class='iribbon-opacity-out'>About us</a></li>
            		<li><a href="https://informa.com/Investors/" tabindex="-1" class='iribbon-opacity-out'>Investor relations</a></li>
            		<li><a href="https://informa.com/Talent/" tabindex="-1" class='iribbon-opacity-out'>Talent</a></li>
        		</ul>
    		</div>
    			<div id="iribbon-right">
        			<p>This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them. Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.</p>
    			</div>
			</div>
	</div>
	<!-- Informa Branding code goes here-->
	<!-- Beginning Sync AdSlot 19 for Ad unit Gamasutra//consolepc ### size: [[2,2]]  -->
<div id='div-gpt-ad-welcome'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-welcome');
	}
	);
 </script>
</div>
<!-- End AdSlot 19 -->
	<!-- Beginning Sync AdSlot 20 for Ad unit Gamasutra//consolepc ### size: [[7,7]]  -->
<div id='div-gpt-ad-mi'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-mi');
	}
	);
 </script>
</div>
<!-- End AdSlot 20 -->
    <div class="hide-phone">
                                <!-- Beginning Sync AdSlot 1 for Ad unit Gamasutra//consolepc ### size: [[1,2]]  -->
<div id='div-gpt-ad-skin'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-skin');
	}
	);
 </script>
</div>
<!-- End AdSlot 1 -->
            </div>
	
	<div class="container"> 
	<div id="container-main" class="content-body-wrapper" style="opacity:0;">
	<script src="/prestitial/adblockDetector.js"></script>
	<!-- Google Prestitial Ads start here-->
	<script>
	  
	  var isblocked = "notblocked";
	  if(!document.getElementById('xRokYeIsHL')){
	   isblocked = "blocked";
	  }
	  console.log('lpage==>' + isblocked);
	  if (isblocked == "notblocked") {
		setTimeout(function() {
		console.log('5 second timeout ');
		unhideMainContent();
		}, 5000);
		googletag.pubads().addEventListener('slotRenderEnded', function(event) {
		  if(event.slot.getSlotElementId() == "div-gpt-ad-welcome")
			{
			console.log('interstitial unit found');
			if(event.isEmpty) {
			  console.log('empty Interstitial');
			   unhideMainContent();
			}
			else {
			  console.log('not empty Interstitial');
			}
		  }
		});
		googletag.enableServices();
	  }else{
		  unhideMainContent();
	  }
	function unhideMainContent() {
		console.log('unhide main content');
		var bDiv = document.getElementsByClassName("content-body-wrapper");

		for (var i=0; i<bDiv.length; i++) {
		  if(bDiv[i].style.removeProperty) {
		   bDiv[i].style.removeProperty('opacity');
		  } 
		  else {
			bDiv[i].style.removeAttribute('opacity');
		  }
		}
	}
	
	</script>
	<!-- Google  Prestitial Ads end here-->
	
    <div class="hide-phone">
         <div class="wrapper properties">
            
		
         </div><!--end wrapper-->
    </div>
    
    <br />
     <div class="container bottom3">
     	<div class="span-7">
          	<a href="https://gamasutra.com"><img src="https://twimgs.com/gamasutra/images/gamasutra_logo.png" alt="Gamasutra: The Art &amp; Business of Making Games" width="243" height="77" border="0" /></a><img alt="spacer" src="https://twimgs.com/gamasutra/images/spacer.gif" width="27" />
		</div>
          <div class="hide-phone">
              <div class="div span-16 last leaderboard">
                     
                                                                               <!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra//consolepc ### size: [[728,90]]  -->
<div id='div-gpt-ad-top'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-top');
	}
	);
 </script>
</div>
<!-- End AdSlot 2 -->
                                           
    
              </div>
          </div>
    </div>

		<div class="span-20">
			<div class="show-phone clearfix" style="padding:0px 0 5px 0"><!--sadie change-->
                        <div class="span-5 center ">
								<!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra//consolepc ### size: [[300,50]]  -->
<div id='div-gpt-ad-mobile_leaderboard'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-mobile_leaderboard');
	}
	);
 </script>
</div>
<!-- End AdSlot 2 -->

                        </div>
				</div>

                    <div class="show-phone"><!--there is another on the page for the regular size, this is phone only-->
                         <div class="span-5 last nav_search">
                              <div class="content center">
                                   <span class="nav_searchtxt">SEARCH</span>
                                   <form class="left" name="topsearchph" action="/search/" method="GET">
          
                                               <input name="search_text" type="text" size="25" class="search" />	  
                                              <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearchph.submit(); return false;">GO</a></span>
                                   
                                   </form>
                              </div>
                         </div>
                    </div><!--end show phone-->
                    
                    <div class="show-phone"><!--sadie change-->
                        <div class="span-3">
                                  <div class="login_phone" id="login_phone">
                                       
                                   </div>
                        </div>
                    </div><!--end showphone-->
                    <div class="nav">
                	<div class="span-3 nav_jobs">
                    	<div class="content">
                              <a href="https://jobs.gamasutra.com/">GAME JOBS</a>
                          </div>
                    </div>
                    <div class="span-12 nav_links">
                         <div class="content">
                                   <a href="/updates/">updates</a>
                                   <a href="/blogs/">Blogs</a>
                                   
                                   <a href="/contractors/contractor_display.php">contractors</a>
                                   <a href="/newsletter-signup">newsletter</a>
                                   <a target="_blank" href="https://www.gamecareerguide.com" style="color:#664271;">Game Career Guide</a>
                         </div>
                    </div>
                    <div class="hide-phone">
                        <div class="span-5 last nav_search">
                             <div class="content">
                                  <span class="nav_searchtxt">SEARCH</span>
                                  <form class="left" name="topsearch" action="/search/" method="GET">

                                              <input name="search_text" type="text" size="10" class="search" />	  
                                             <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearch.submit(); return false;">GO</a></span>

                                    </form>
                             </div>
                        </div>
                    </div>
                    <br class="clear">
               </div><!--end nav-->
               <div class="hide-phone"> 
                    <div class="span-20 last"> 
                       <div class="topicmenu">
                            <ul>
                                <li class="activetab"><a href="https://gamasutra.com">ALL</a>
                                </li><li ><a href="/topic/console-pc">CONSOLE/PC</a>
                                </li><li ><a href="/topic/smartphone-tablet">SMARTPHONE/TABLET</a>
                                </li><li ><a href="/topic/indie">INDEPENDENT</a>
                                </li><li ><a href="/topic/vr">VR/AR</a>
                                </li><li ><a href="/topic/social-online">SOCIAL/ONLINE</a>
                                </li></ul>
                                                          <span class="gdmag"><a href="/topic/game-developer"><img src="https://twimgs.com/gamasutra/images/btn_gdmag0.png" width="118px" height="33px"></a></span>
                       </div>
                   </div>
               </div>		
                    <div class="span-20 last content_bg">
                        <div class="hide-phone">
<div class="span-4">
  <div class="content_box_left">
    <div class="leftcol">
        <!--member login-->
                    <table width="166" border="0" cellspacing="0" cellpadding="0">
  <tr>   
    <td id="memberLogin" class="welcome">
    	
    </td>   
  </tr>
</table>                 <!--end memberlogin-->
        
        <!--begin social icons-->
            <!--begin social icons-->
<div  class="bottom2">
    <ul class="leftcol_social">
       <li class="facebook"><a href="https://www.facebook.com/pages/Gamasutra/31610613408" target="_blank">&nbsp;</a></li>
       <li class="twitter"><a href="https://twitter.com/gamasutra" target="_blank">&nbsp;</a></li>
       <li class="feed"><a href="https://gamasutra.com/static2/rssfeeds.html">&nbsp;</a></li>
       <li class="newsletter"><a href="/newsletter-signup">&nbsp;</a></li>
    </ul>
</div>
<!--end social icons-->        <!--end social icons-->
        
        <!--begin page numbers-->
                <!--end page numbers-->
        
        <!--begin leftnav-->
                <div class="leftnav_categories bottom2">
   <a href="/category/programming/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_programming.gif"  width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/programming/">PROGRAMMING</a></div>

   <hr>

   <a href="/category/art/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_art.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/art/">ART</a></div>

   <hr>

   <a href="/category/audio/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_audio.gif" width="24px" height="24px"  /></a>         
   <div class="leftnav_btn"><a href="/category/audio/">AUDIO</a></div>

   <hr>

   <a href="/category/design/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_design.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/design/">DESIGN</a></div>

   <hr>

   <a href="/category/production/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_production.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/production/">PRODUCTION</a></div>

   <hr>
   <a href="/category/business-marketing/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_business.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/business-marketing/">BIZ/MARKETING</a></div>

   <br class="clear">
</div>          <!--end leftnav-->
                  
                    <!-- Beginning Sync AdSlot 3 for Ad unit Gamasutra//consolepc ### size: [[164,59]]  -->
<div id='div-gpt-ad-button1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-button1');
	}
	);
 </script>
</div>
<!-- End AdSlot 3 -->
            <!-- Beginning Sync AdSlot 4 for Ad unit Gamasutra//consolepc ### size: [[164,59]]  -->
<div id='div-gpt-ad-button2'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-button2');
	}
	);
 </script>
</div>
<!-- End AdSlot 4 -->
            <!-- Beginning Sync AdSlot 5 for Ad unit Gamasutra//consolepc ### size: [[164,409]]  -->
<div id='div-gpt-ad-callout'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-callout');
	}
	);
 </script>
</div>
<!-- End AdSlot 5 -->
            <!-- Beginning Sync AdSlot 9 for Ad unit Gamasutra//consolepc ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-custom1');
	}
	);
 </script>
</div>
<!-- End AdSlot 9 -->
            <!-- Beginning Sync AdSlot 11 for Ad unit Gamasutra//consolepc ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom3'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-custom3');
	}
	);
 </script>
</div>
<!-- End AdSlot 11 -->
                
        <!-- begin event tickers -->
			              
        <!-- end event tickers -->
	
         <!--begin jobs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_jobs.png" width="22px" height="20px"/><a href="https://jobs.gamasutra.com/">Latest Jobs</a></div>
<div class="leftnav bottom2">
     <a href="https://jobs.gamasutra.com/"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp;
     <a href="https://feeds.feedburner.com/GamasutraJobs"><strong>RSS</strong></a>
     <hr>
     <strong>March 31, 2020</strong>
     <hr>
     <ul>    
            <li>Infinity Ward<br />
              <a href="https://jobs.gamasutra.com/job/ai-engineering-director-woodland-hills-california-34375">AI Engineering Director</a>
        </li>
        <li class="line"></li>
            <li>Visual Concepts<br />
              <a href="https://jobs.gamasutra.com/job/animation-engineer-agoura-hills-california-34362">Animation Engineer</a>
        </li>
        <li class="line"></li>
            <li>Visual Concepts<br />
              <a href="https://jobs.gamasutra.com/job/senior-server-engineer-novato-california-34361">Senior Server Engineer</a>
        </li>
        <li class="line"></li>
            <li>Visual Concepts<br />
              <a href="https://jobs.gamasutra.com/job/gameplay-software-engineer-novato-california-34360">Gameplay Software Engineer</a>
        </li>
        <li class="line"></li>
            <li>Visual Concepts<br />
              <a href="https://jobs.gamasutra.com/job/graphics-engineer-foothill-ranch-california-34359">Graphics Engineer</a>
        </li>
        <li class="line"></li>
            <li>Visual Concepts<br />
              <a href="https://jobs.gamasutra.com/job/senior-software-engineer-unreal-engine-foothill-ranch-california-34358">Senior Software Engineer - Unreal Engine</a>
        </li>
        <li class="line"></li>
         </ul>    
</div>
         <!--end jobs-->   
           			
         <!--begin blogs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/><a href="/blogs/">Latest Blogs</a></div>
<div class="leftnav bottom2">
    <a href="/blogs/"><strong>View All</strong></a> 
    &nbsp;&nbsp;&nbsp; <a href="/blogs/edit/"><strong>Post</strong></a>
    &nbsp;&nbsp;&nbsp; <a href="/blogs/rss/"><strong>RSS</strong></a>
    <hr>
    <strong>March 31, 2020</strong>
    <hr>   
    <ul>
        
        <li>
            <a href="/blogs/RubenTorresBonet/20200330/360305/Unity_C_Improved_Out_Parameters_C_70.php">Unity C#: Improved Out Parameters (C# 7.0)</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/SimonCarless/20200327/360280/Showcasing_on_Steams_Game_Festival_the_real_numbers.php">Showcasing on Steam's Game Festival: the real numbers!</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/CrystinCox/20200327/360105/Understanding_LiveOps_Doing_LiveOps.php">Understanding LiveOps, Doing LiveOps</a>
             
                [<a title="1 comments" href="/blogs/CrystinCox/20200327/360105/Understanding_LiveOps_Doing_LiveOps.php#comments">1</a>]
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/RubenTorresBonet/20200325/360052/How_to_Stop_the_Spread_of_Overdraw_Before_It_Kills_Your_Game.php">How to Stop the Spread of Overdraw (Before It Kills Your Game)</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/JunxueLi/20200324/358838/Guide_for_Game_Industry_Talents_Who_Wish_to_Work_in_China.php">Guide for Game Industry Talents Who Wish to Work in China</a>
                    </li>
        <li class="line"></li>
       
    </ul>
</div>
         <!--end blogs-->
         
         <!--begin press releases-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/>Press Releases</div>
<div class="leftnav bottom2">
    <strong>March 31, 2020</strong>
	<hr>
	       <a href="/pressreleases_index.php"><strong>Games Press</strong></a>
   <hr>
   <ul>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/360365/MEET_THE_ENSEMBLE_EIGHT_TALENTS_FEATURED_IN_LONDON_GAMES_FESTIVALS_2020_BAME_SHOWCASE.php">MEET THE ENSEMBLE: EIGHT<br />
TALENTS FEATURED IN...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/360366/Take_a_walk_on_the_wild_side_with_Planet_Zoo_South_America_Pack_PDLC.php">Take a walk on the wild<br />
side with Planet Zoo:...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/360367/Virtual_Battlegrounds_takes_the_fight_for_Battle_Royale_supremacy_to_the_PC_VR_enthusiast_crowd.php">Virtual Battlegrounds<br />
takes the fight for<br />
Battle...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/360362/Coming_soon_Cosmos_Elite_Headset_HMD_only_and_External_Tracking_Faceplate_both_paired_with_HalfLife_Alyx.php">Coming soon: Cosmos Elite<br />
Headset (HMD only) and...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/360363/Epic_Games_find_out_how_students_put_Unreal_Engine_through_its_paces.php">Epic Games find out how<br />
students put Unreal<br />
Engine...</a>
        </li>
        <li class="line"></li>
         </ul>
   <a href="/pressreleases_index.php"><strong>View All</strong></a> 
   &nbsp;&nbsp;&nbsp; <a href="/pressreleases/rss/"><strong>RSS</strong></a>
</div>         <!--end press releases-->
                         
         <!--begin calendar-->
            <!--

<div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_calendar.png" width="22px" height="20px"/><a href="http://gamasutra.com/calendar/calendar.php">Calendar</a></div>
<div class="leftnav bottom2">
    <a href="http://gamasutra.com/calendar/calendar.php"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp; <a href="http://gamasutra.com/calendar/calendar_submit.php"><strong>Submit Event</strong></a>
    <hr>
    <ul>
        
    </ul>
</div>

-->         <!--end calendar-->
                         
         <!--begin about-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="/contactus">About</a></div>
<div class="leftnav bottom2">
    <ul>
            <li><strong>Editor-In-Chief: </strong><br /><a href="/cdn-cgi/l/email-protection#6a010d180b0c1e2a0d0b070b191f1e180b44090507">Kris Graft</a></li>
            <li class="line"></li>
         
       
            <li><strong> Editor: </strong><br /> <a href="/cdn-cgi/l/email-protection#e889848d90c69f899f9a87a89d8a85c68b8785">Alex Wawro</a></li>
			<li class="line"></li>
            
			<li><strong>News Editor: </strong><br /> <a href="/cdn-cgi/l/email-protection#dcbdb0b5afafbdf2b1bfbdb0b3b3b29ca9beb1f2bfb3b1">Alissa McAloon</a></li>
            <li class="line"></li>
            
            <li><strong>Contributors: </strong><br />
				Chris Kerr<br />
				Bryant Francis<br />
				Katherine Cross<br />
			</li>	
            <!--<li><strong>Advertising: </strong><br /><a href="mailto:sales@gamasutra.com?subject=Request%20Info:%20Gamasutra">sales@gamasutra.com</a></li>-->
    </ul>
    <hr>
    <div class="center"><a href="/contactus">Contact Gamasutra</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#e695939696899492a681878b879593929487c885898b">Report a Problem</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#2e404b595d6e494f434f5d5b5a5c4f004d4143">Submit News</a></div>
    <hr>
    <div class="center"><a href="/static2/comment_guidelines.html">Comment Guidelines</a></div>
    <hr>
    <div class="center"><a href="/static2/blogsubmissions.html">Blogging Guidelines</a></div>
    <hr>
    <div class="center"><a href="/static2/howwework.html">How We Work</a></div>
	<!--<hr>
	<div class="center"><a href="/advertise">Advertise with Gamasutra</a></div>-->
	<hr>
    <div class="center"><a href="http://reg.gdconf.com/gama20-media-kit">Download Media Kit</a></div>
</div>

<div class="bottom2">
    <a href="/advertise">
        <img src="https://twimgs.com/gamasutra/images/AdwGama_177x60_button_v1.jpg" alt="Sponsor" border="0" class="whiteTop"  width="177px" height="60px"/>
    </a>
</div>
             <!--end about-->
         
         <!--begin network-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="#">Gama Network</a></div>
<div class="leftnav_network bottom2">
    If you enjoy reading this site, you might also want to check out these UBM Tech sites:
    <hr>
    <a href="https://www.gamecareerguide.com"><!-- img src="http://www.indiegames.com/blog/gcgmini.jpg" align="left" hspace="2"/ --></a> 
    <div class="leftnav_btn"><a href="https://www.gamecareerguide.com">Game Career Guide</a></div>
    <hr>
    <a href="https://www.indiegames.com/blog"><!-- img src="http://www.indiegames.com/blog/indiemini.jpg" align="left" hspace="2"/ --></a>
    <div class="leftnav_btn"><a href="https://www.indiegames.com/blog">Indie Games</a></div>
    <br class="clear">
</div>         <!--end network-->
         
         <!--begin store-->
                     <!--end store-->
         
                
    </div><!--end leftcol-->
  </div>
</div> 
</div>  	<style>.content_box_middle pre {
		overflow-x:auto;
	}
	.item_title{
		    margin-top: 0px !important;
			margin-bottom: 0px !important;
	}
	</style>
<div class="span-16 last">
    <div class="content_box_middle">
        <!-- InstanceBeginEditable name="BodyContent" --> 
        <div class="header_large">
            <span class="left"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png"/><a href="/blogs/">Blogs</a></span>
        </div>
        <div class="page_item"> 
                        <div class="clear">&nbsp;</div>
            <h1 class="item_title">Unity C#: Improved Out Parameters (C# 7.0)</h1>
            <div>
                <span class="newsAuth">by <a href="/blogs/author/RubenTorresBonet/1009721/">Ruben Torres Bonet</a> on 03/30/20 10:31:00 am 
                    &nbsp; <img valign="bottom" border="0" src="https://twimgs.com/gamasutra/images/expertIcon_gamaBlog.gif" alt="Expert Blogs" />                    &nbsp; <img valign="bottom" border="0" src="https://twimgs.com/gamasutra/images/featuredIcon_gamaBlog.gif" alt="Featured Blogs" />                                        <br />
                </span>
            </div>
            <div>
                <br>
                                    <span class="comment_text">
                                                    <a href="#comments">Post A Comment</a>
                                            </span>
                    <a name="twitter_share" type="button" href="http://twitter.com?status=RT @gamasutra: Unity C#: Improved Out Parameters (C# 7.0) http://www.gamasutra.com/blogs/RubenTorresBonet/20200330/360305/" target="_blank"><img src="https://twimgs.com/gamasutra/images/twitter.gif" alt="Share on Twitter" border="0" height="20"/></a>
                    <iframe src="https://www.facebook.com/plugins/share_button.php?href=https://www.gamasutra.com/blogs/RubenTorresBonet/20200330/360305/&layout=button&size=large&mobile_iframe=true&width=72&height=28&appId" width="72" height="28" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>

                    <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
                    <g:plusone size="medium" count="false"></g:plusone>
					<span id="edit_post_link"></span>&nbsp;&nbsp;
					<a href="/blogs/rss/"><img src="https://twimgs.com/gamasutra/images/icon_rss.gif" width="15" height="15" border="0" alt="RSS" /></a>
                            </div>
            <hr>
            <div class="item_body mobile_image_transform">       
                <strong><i><small>
                    The following blog post, unless otherwise noted, was written by a member of Gamasutra&#146;s community.<br />
					The thoughts and opinions expressed are those of the writer and not Gamasutra or its parent company.                </small></i></strong>
                <hr>
                <div class="clear">&nbsp;</div>
                <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd">
<html><body><section data-css="tve-u-16f89b682a9"><p>Today I'm starting a new series of short posts about neat C# features that many Unity game developers are missing on. In this post, you will learn about the improved&nbsp;<strong>Unity C# out Parameters&nbsp;</strong>feature that is available since C# 7.0.</p>
<img alt="" data-css="tve-u-171262d884b" data-id="6402" data-lazy-sizes="(max-width: 938px) 100vw, 938px" data-lazy-src="https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail.jpg" data-lazy-srcset="https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail.jpg 938w, https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail-300x160.jpg 300w, https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail-469x250.jpg 469w, https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail-768x409.jpg 768w" data-was-processed="true" height="255" sizes="(max-width: 938px) 100vw, 938px" src="https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail.jpg" srcset="https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail.jpg 938w, https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail-300x160.jpg 300w, https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail-469x250.jpg 469w, https://thegamedevguru.b-cdn.net/wp-content/uploads/2020/03/Unity-C-Out-Parameters-Thumbnail-768x409.jpg 768w" width="479"><p>When programming your game, you'll often run into the need of returning multiple values within from a function.</p>

<p>Traditionally speaking, you have several ways to return multiple values.</p>

<p>In C++ is very common to use&nbsp;<strong>pointers/references</strong>&nbsp;as a way to return modified or even new variables. This often comes with requiring strong naming conventions to make it clear the function will modify these variables, e.g:</p>

<pre><code>int Raycast(const Vector3&amp; Direction, const Vector3&amp; Position, HitResult** OutHitResult);</code></pre>

<p>Another approach is to create&nbsp;<strong>aggregating structures</strong>&nbsp;that contain all the data you want to return. This method is verbose, but having named variables increases code clarity, e.g:</p>

<pre><code>struct RaycastHitResult
{
  int NumberTotalHits;
  Collider FirstTargetHit;
}
RaycastHitResult Raycast(const Vector3&amp; Direction, const Vector3&amp; Position);</code></pre>

<p>On top of this, some languages offer tuples. C# has great support for tuples as we'll see in an upcoming post.</p>

<p>But as of today, I'll show you a neat variation C# offers you to return multiple values:&nbsp;<strong>Unity C# out parameters</strong>.</p>
<strong>Quick Navigation</strong>

<p><a href="https://thegamedev.guru/unity-c-sharp/out-parameters-7-0/#tab-con-3" rel="nofollow">What Are Unity C# Out Parameters?</a></p>

<p><a href="https://thegamedev.guru/unity-c-sharp/out-parameters-7-0/#tab-con-4" rel="nofollow">How Did C# 7.0 Improve C# Out Parameters?</a></p>

<p><a href="https://thegamedev.guru/unity-c-sharp/out-parameters-7-0/#tab-con-8" rel="nofollow">Examples</a></p>

<p><a href="https://thegamedev.guru/unity-c-sharp/out-parameters-7-0/#tab-con-5" rel="nofollow">1. Unity Raycasting</a></p>

<p><a href="https://thegamedev.guru/unity-c-sharp/out-parameters-7-0/#tab-con-6" rel="nofollow">2. C# Data Parsing</a></p>

<p><a href="https://thegamedev.guru/unity-c-sharp/out-parameters-7-0/#tab-con-7" rel="nofollow">3. C# Dictionaries</a></p>

<p><a href="https://thegamedev.guru/unity-c-sharp/out-parameters-7-0/#tab-con-1" rel="nofollow">What's Next?</a></p>

<h2 id="tab-con-3">What Are Unity C# Out Parameters?</h2>

<p>C# lets you use the&nbsp;<em><strong>out&nbsp;</strong></em>keyword in function parameters to make the programmer aware those variables will be initialized and set within that function.</p>

<p>In other words:&nbsp;<strong>you pass the function a variable that the function will set for you</strong>.</p>

<p>You can have as many out parameters as you want, which makes them useful to return multiple parameters within a function.</p>

<p>They existed for a long time, but it turns out C# 7.0 improved the way you and I work with these Unity C# out parameters.</p>

<p>Let's see how.</p>

<h2 id="tab-con-4">How Did C# 7.0 Improve C# Out Parameters?</h2>

<p>Till C# 7.0, you had to declare your variables before passing them to the function you're invoking.</p>

<p>This often required an extra line per out variable you want to pass, such as:</p>

<pre><code>ChatMessageType type;
ServerGameLoop.ClientInfo target;

var text = ParseMessage(from, message, out type, out target);

if (type == ChatMessageType.Whisper)
{
  // ...
}</code></pre>

<p>This specific Unity C# out parameter improvement allows us, game developers, to declare these out variables&nbsp;<strong>inline&nbsp;</strong>along the function invocation.</p>

<p>The&nbsp;<strong>scope&nbsp;</strong>of the inline-declared variables is exactly the same as it used to be when declaring them before the function call.</p>

<p>And you can declare these inline out parameters with an explicit type or by using automatic type inference (<em>var</em>).</p>

<p>This way, you can turn the previous example into:</p>

<p><strong>Either this:</strong></p>

<pre><code>var text = ParseMessage(from, message, out var type, out var target);
if (type == ChatMessageType.Whisper)
{
  // ...
}</code></pre>

<p><strong>Or this:</strong></p>

<pre><code>var text = ParseMessage(from, message, out ChatMessageType type, out ServerGameLoop.ClientInfo target);
if (type == ChatMessageType.Whisper)
{
  // ...
}</code></pre>

<p>Even though the Unity API barely uses C# out parameters, I certainly see many Unity projects using those in their code base. That's why this post is relevant for many of you, Unity game developers.</p>

<p>Let's see some examples.</p>

<h2 id="tab-con-8">Examples</h2>

<h3 id="tab-con-5">1. Unity Raycasting</h3>

<p>Raycasting has many applications, such as for AI to detect line of sight.</p>

<p>In Unity, you cast rays through the&nbsp;<em>Physics API</em>.</p>

<p>Here's the C# 7.0 transformation:</p>

<p><strong>From:</strong></p>

<pre><code>RaycastHit raycastHit;
if (Physics.Raycast(cosmicRay, out raycastHit))
{
  Debug.Log("Hit ya " + raycastHit.collider.name);
}</code></pre>

<p><strong>To:</strong></p>

<pre><code>if (Physics.Raycast(cosmicRay, out RaycastHit raycastHit))
{
  Debug.Log("Hit ya " + raycastHit.collider.name);
}</code></pre>

<p><em>* Avoid using Physics.Raycast, as this version allocates memory and is detrimental to performance. Use&nbsp;<a href="https://docs.unity3d.com/ScriptReference/Physics.RaycastNonAlloc.html" target="_blank">Physics.RaycastNonAlloc</a>instead.</em></p>

<h3 id="tab-con-6">2. C# Data Parsing</h3>

<p>Sometimes you have to do conversions from string to other types, such as when reading from a configuration file or user input.</p>

<p>C# makes this easy with TryParse, which uses an out parameter to give you what you wanted. here, we can profit from the improved Unity C# out parameters:</p>

<p><strong>From:</strong></p>

<pre><code>int hitpoints;
if (int.TryParse(hitpointsString, out hitpoints))
{
  Debug.Log($"You're {hitpoints} hitpoints away from table flipping");
}</code></pre>

<p><strong>To:</strong></p>

<pre><code>if (int.TryParse(hitpointsString, out int hitpoints))
{
  Debug.Log($"You're {hitpoints} hitpoints away from table flipping");
}</code></pre>

<p>The pattern same applies to&nbsp;<em>float</em>,&nbsp;<em>double</em>,&nbsp;<em>long</em>, etc..</p>

<h3 id="tab-con-7">3. C# Dictionaries</h3>

<p>I love dictionaries.</p>

<p>C# dictionaries have the famous&nbsp;<em>TryGetValue&nbsp;</em>method, which can become quite verbose after using it so many times.</p>

<p>It gets old very quickly.</p>

<p>Suppose we have a dictionary that maps inventory slots to game objects representing items (I don't say this is a good idea, eh):</p>

<pre><code>int slotId = 1;
var inventory = new Dictionary&lt;int, GameObject&gt;();</code></pre>

<p>We can then improve our coding style...</p>

<p><strong>From:</strong></p>

<pre><code>GameObject item;
if (inventory.TryGetValue(slotId, out item))
{
  Debug.Log($"Looted {item.name}");
}</code></pre>

<p><strong>To:</strong></p>

<pre><code>if (inventory.TryGetValue(slotId, out GameObject item))
{
  Debug.Log($"Looted {item.name}");
}</code></pre>

<h2 id="tab-con-1">What's Next?</h2>

<p>This improved version of C# out parameters is a neat little addition to remove verbosity from your code.</p>

<p>Some people will like it, some won't.</p>

<p>And that's fine. Just choose one style and stick to it.</p>

<p>In the next post in the C# series, I'll show you an additional way of returning multiple values with C# 7.0.</p>

<p>Till then, why don't you have a look at how&nbsp;<a href="https://thegamedev.guru/unity-addressables/benefits-for-your-game/">Unity Addressables</a>&nbsp;will save you from development pain?</p>

<p>~Ruben</p>
</section></body></html>

            </div>   
                                                <hr>
                    <div class="hide-phone">
                        <h3>Related Jobs</h3>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/ai-engineering-director-woodland-hills-california-34375"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1009644.gif" alt="Infinity Ward" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Infinity Ward &mdash; 
                                                                          Woodland Hills,
                                                                                                              California,
                                                                        United States
                                    <br />
                                    [03.30.20]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/ai-engineering-director-woodland-hills-california-34375">AI Engineering Director</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/animation-engineer-agoura-hills-california-34362"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1033549.png" alt="Visual Concepts" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Visual Concepts &mdash; 
                                                                          Agoura Hills,
                                                                                                              California,
                                                                        United States
                                    <br />
                                    [03.27.20]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/animation-engineer-agoura-hills-california-34362">Animation Engineer</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/senior-server-engineer-novato-california-34361"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1033549.png" alt="Visual Concepts" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Visual Concepts &mdash; 
                                                                          Novato,
                                                                                                              California,
                                                                        United States
                                    <br />
                                    [03.27.20]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/senior-server-engineer-novato-california-34361">Senior Server Engineer</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/gameplay-software-engineer-novato-california-34360"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1033549.png" alt="Visual Concepts" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Visual Concepts &mdash; 
                                                                          Novato,
                                                                                                              California,
                                                                        United States
                                    <br />
                                    [03.27.20]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/gameplay-software-engineer-novato-california-34360">Gameplay Software Engineer</a>
                                </div>
                           </div>
                                            </div>
                    <br class="clear"/><br/>
                    <div class="right small">
                        <strong>[<a href="https://jobs.gamasutra.com/">View All Jobs</a>]</strong>
                    </div>
                    <br class="clear"/><br/>
                                        <hr>
            							<script type='text/javascript'>
																
								//Rectangle 1 on small mobile device
								if (document.documentElement.clientWidth <= 767)
								{ document.write('<div id="div-gpt-ad-rec1"><center>'); 
										googletag.cmd.push(function(){
											googletag.display('div-gpt-ad-rec1'); 
										});
										document.write('</center></div>'); }
								
							</script>


                <div id="dynamiccomments">
					<span id="cmtArticleId" style="display:none">360305</span>
					<span id="cmtStory_type" style="display:none">blog</span>
					<span id="cmtArticleUri" style="display:none">/blogs/RubenTorresBonet/20200330/360305/Unity_C_Improved_Out_Parameters_C_70.php?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+GamasutraFeatureArticles+%28Gamasutra+Feature+Articles%29</span>
					<span id="author_id" style="display:none">1009721</span>
					<span id="author_user_id" style="display:none">37622403</span>
                    <a style="font-weight: bold; font-size: 16px;" name="comments"> Loading Comments</a>
                    <br />
                    <hr noshade size="1" class="hr_comment">
                
                    <div align="center">
                         <img style="padding-top: 2px; padding-right: 5px; padding-bottom: 5px;" alt="loader image" src="/ajax-loader.gif"/>
                    </div>
       
                </div>
                    </div>  
        <!-- InstanceEndEditable -->
    </div><!--end contentbox-->
</div><!--end span-16-->

            </div>
            <br class="clear">
	</div><!--end span-21-->

        <!--begin right sidebar-->
     	<div class="hide-phone center">
               <div class="span-4 last">
                   <!--right hand ads start here-->

  
                            <!-- Beginning Sync AdSlot 7 for Ad unit Gamasutra//consolepc ### size: [[160,600]]  -->
<div id='div-gpt-ad-sky1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-sky1');
	}
	);
 </script>
</div>
<!-- End AdSlot 7 -->
        <!-- Beginning Sync AdSlot 8 for Ad unit Gamasutra//consolepc ### size: [[160,160]]  -->
<div id='div-gpt-ad-Ltile1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-Ltile1');
	}
	);
 </script>
</div>
<!-- End AdSlot 8 -->
      
		 
               	</div>
                 </div>
     <!--end right sidebar-->         
        <!-- </div> Extra Div -->
					<!-- Beginning Sync AdSlot 21 for Ad unit Gamasutra//consolepc ### size: [[8,2]]  -->
<div id='div-gpt-ad-native'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-native');
	}
	);
 </script>
</div>
<!-- End AdSlot 21 -->
			<!-- Beginning Sync AdSlot 22 for Ad unit Gamasutra//consolepc ### size: [[8,4]]  -->
<div id='div-gpt-ad-insight'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-insight');
	}
	);
 </script>
</div>
<!-- End AdSlot 22 -->
			<!-- Beginning Sync AdSlot 23 for Ad unit Gamasutra//consolepc ### size: [[4,4]]  -->
<div id='div-gpt-ad-video'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-video');
	}
	);
 </script>
</div>
<!-- End AdSlot 23 -->
				
     
     <br class="clear">
<link rel="stylesheet" type="text/css" href="https://twimgs.com/informationweek/footernav/jan2015/css/superfooter_dark.css" />
<link rel="stylesheet" type="text/css" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" />
<link rel="stylesheet" type="text/css" href="https://twimgs.com/nojitter/css/common-footer.css?" />
<div align="center">
          <!-- Beginning Sync AdSlot 6 for Ad unit Gamasutra//consolepc ### size: [[3,3]]  -->
<div id='div-gpt-ad-ribbon'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-ribbon');
	}
	);
 </script>
</div>
<!-- End AdSlot 6 -->
</div>

</div><!--end content-body-wrapper-->
     </div><!--end container-->
<!--begin footer-->
<style type="text/css">

@media (min-width: 992px){
	.col-md-5.discover {
		width:47%;
	}
	.divisional-footer .divisional-footer-container .col-md-2 ul{
		padding-right: 28%;
	}
	.col-md-5.brand-name {
		width:27%;
	}
	.col-md-6.logo{
		width: 48%;
		padding: 0.5% 0px;
	}
	.col-md-12 p{
		padding-left:40%;
	}
}

</style>
<footer id="#informa-footer">
        <div class="divisional-footer" style="/*padding-left:10px;padding-right:10px;*/max-width:none;">
            <div class="divisional-footer-container">
                <!--divisional plus marketing -->
                <div class="alternate">
                    <div class="footer-row" style="border-bottom: 1px solid #fff;">
                        <div class="col-md-5 discover">
                            <div class="heading">Discover more from Informa Tech</div>
                            <ul class="list-inline">
                                <li><a href="https://www.gdconf.com" title="Game Developers Conference" target="_blank">Game Developers Conference</a></li>
								<li><a href="https://igf.com/" title="Independent Games Festival" target="_blank">Independent Games Festival</a></li>		
								<li><a href="https://jobs.gamasutra.com/" title="Gamasutra Jobs" target="_blank">Gamasutra Jobs</a></li>		
								<li><a href="https://www.gamechoiceawards.com/" title="Game Developers Choice Awards" target="_blank">Game Developers Choice Awards</a></li>		
								<li><a href="https://www.gdcvault.com/" title="GDC Vault" target="_blank">GDC Vault</a></li>		
								<li><a href="https://ovum.informa.com/resources/key-topics/video-gaming" title="Ovum" target="_blank">Ovum</a></li>		
								<li><a href="https://www.gamecareerguide.com/" title="Game Career Guide" target="_blank">Game Career Guide</a></li>		
								<li><a href="https://technology.ihs.com/Categories/450469/games-market" title="IHS" target="_blank">IHS</a></li>
                            </ul>
                        </div>
                        <div class="col-md-2 working">
                            <div class="heading">Working With Us</div>
                            <ul class="list-inline">
								<li>
                                    <a href="https://www.gamasutra.com/contactus">Contact us</a>
                                </li>
                                <li>
                                    <a href="https://www.gamasutra.com/static2/howwework.html">About Us</a>
                                </li>
                                <li>
                                    <a
                                        href="https://www.gamasutra.com/advertise">Advertise</a>
                                </li>
                            </ul>
                        </div>
                        <div class="col-md-5 brand-name">
                            <div class="heading">Follow gamasutra on Social </div>
                            <ul class="list-inline social-icon">
                                <li>
                                    <a href="https://www.facebook.com/pages/Gamasutra/31610613408"><i
                                            class="facebook-white trigger-sc-event"
                                            data-goal-id="715A59A2-A9FC-44E0-B4AF-8A960F2A5116"></i></a>
                                </li>
                                <li>
                                    <a href="https://twitter.com/gamasutra"><i
                                            class="twitter-white trigger-sc-event"
                                            data-goal-id="715A59A2-A9FC-44E0-B4AF-8A960F2A5116"></i></a>
                                </li>
                                <li>
                                    <a href="https://www.gamasutra.com/static2/rssfeeds.html"><i class="rss-feed-white trigger-sc-event"
                                            data-goal-id="715A59A2-A9FC-44E0-B4AF-8A960F2A5116"></i></a>
                                </li>
                            </ul>
                        </div>
                    </div>
                </div>
                <!--DIV-->
            </div>
        </div>

        <div class="divisional-footer">
            <div class="divisional-footer-container">
                <div class="footer-row footer-icons">
                    <div class="col-md-6 logo" style="padding: 0.5% 0px;">
                        <img src="https://twimgs.com/nojitter/img/Whitelogo.png" alt="alt text of the logo">
                    </div>

                    <div class="col-md-6">
                        <ul class="list-inline">
							<li>
                                <a href="https://tech.informa.com/" target="_blank">Home</a>
                            </li>
                            <li>
                                <a href="https://tech.informa.com/cookie-policy" target="_blank">Cookies</a>
                            </li>
							<li>
                                <a href="https://privacyportal-eu-cdn.onetrust.com/dsarwebform/c1f53e84-9f05-4169-a854-85052b63c50b/5f26b553-52cc-4973-a761-295d5634a6b6.html" target="_blank">CCPA: Do not sell my personal info</a>
                            </li>
                            <li>
                                <a href="https://tech.informa.com/privacy-policy" target="_blank">Privacy</a>
                            </li>
                            <li>
                                <a href="https://tech.informa.com/terms-and-conditions" target="_blank">Terms</a>
                            </li>
                        </ul>
                    </div>
                </div>
                <div class="footer-row privacy-policy">
                    <div class="col-md-12">
                        <p class="copyright">Copyright &copy; 2020 Informa PLC
                            Informa UK Limited is a company registered in England and Wales with company number 1072954
                            whose registered office is 5 Howick Place, London, SW1P 1WG.
                        </p>
                    </div>
                </div>
            </div>
        </div>
    </footer>
<!--end footer-->

<script type="text/javascript" src="https://ins.techweb.com/beacon/js/beacon-min.js"></script>
<script type="text/javascript">
var beacon = new UBM.Beacon({environment: 'p', apiKey: '31fa8154ead6bb6b2bcefa32b0b2bd86ef990485d4def29a6117223512da2973'});
beacon.pageview();
</script>
<script type="text/javascript">
	var registerData='';
	registerCheck();
	function registerCheck(){
		$.ajax({
			url: '/omnloginstatus.php',
			async : false,
			success: function(result){
				registerData = result.replace('"','');
				registerData = registerData.replace('"','');
			}
		});
	}
</script>

<script type="text/javascript" src="https://twimgs.com/gamasutra/js/combined.js"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/nextgengama.js?v5"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/checkauth.js?v2"></script>
<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/oasTrack_v1.js"></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<!-- SiteCatalyst code version: H.21.
Copyright 1996-2010 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->


<!--<script language="JavaScript" type="text/javascript" src="https://epromos.ubmcanon.com/s_code/ubm-tech-global-app-measurement.js"></script>-->
<script language="JavaScript" type="text/javascript" src="https://i.cmpnet.com/s_code/ubm-tech-global-app-measurement.js"></script>
<script language="JavaScript" type="text/javascript"><!--
    /* You may give each page an identifying name, server, and channel on
    the next lines. */
	s.pageName="";
	s.server="";
	s.channel="";
	s.pageType="";
	s.prop1="";
	s.prop2="360305";
	s.prop3="Gamasustra | 360305 | Unity C#: Improved Out Parameters (C# 7.0)";
	s.prop4="Unity C#: Improved Out Parameters (C# 7.0)";
	s.prop5="GAMASUTRA BLOG";
	s.prop6="";
	s.prop7="Ruben Torres Bonet";
	s.prop8="userAgent";
	s.prop9="";
	s.prop10="";
	s.prop13="";
    s.prop19=registerData;
	s.contextData['Newsletter_signup'] ="";
	/* Conversion Variables */
	s.campaign="";
	s.state="";
	s.zip="";
	s.events="event5";
	s.products="";
	s.purchaseID="";
	s.eVar1="programming,console-pc,serious,indie,social-online,smartphone-tablet,vr";
	s.eVar2="";
	s.eVar3="";
	s.eVar4="";
	s.eVar5="";
	/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
    var s_code = s.t(); if (s_code) document.write(s_code)//--></script>
<script language="JavaScript" type="text/javascript"><!--
    if (navigator.appVersion.indexOf('MSIE') >= 0) document.write(unescape('%3C') + '\!-' + '-')
//--></script><noscript><a href="http://www.omniture.com" title="Web Analytics"><img
src="http://cmp.112.2o7.net/b/ss/cmpglobalvista/1/H.21--NS/0"
height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.21. -->          
  
<!-- Begin ADSNATIVE Code -->
<script type="text/javascript" src="https://static.adsnative.com/static/js/render.v1.js"></script>
<!-- End ADSNATIVE Code -->  
<!--Begin Ad script for pixel --> 

<script type="text/javascript">
    adroll_adv_id = "AJSB6AWABZB2RFHAOYSOZH";
    adroll_pix_id = "2RTKKW6YFBHIVKRM6FNJ4D";
    /* OPTIONAL: provide email to improve user identification */
    /* adroll_email = "username@example.com"; */
    (function () {
        var _onload = function(){
            if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
            if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
                document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
        };
        if (window.addEventListener) {window.addEventListener('load', _onload, false);}
        else {window.attachEvent('onload', _onload)}
    }());
</script>

<!--END Ad script for pixel -->
</body>
</html>                
                