<!doctype html>
<html lang="en">
<head>
  <!-- Google Tag Manager -->
  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-NDKS786');</script>
  <!-- End Google Tag Manager -->
  
	        <!-- <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> -->
		<meta http-equiv='Content-Type' content='text/html; charset=UTF-8' /> 
		<title>Gamasutra: Mason Remaley's Blog - Fullscreen Exclusive Is A Lie (...sort of)</title>
	<meta name="pagecaching" content="888" />
			<meta name="keywords" content="game development, game developer, game programming, game programmer, videogame, artificial intelligence, 3D animation, game design, 3D modeling, game business, game jobs, game directory, game development software, game technology, 3D technology, game producer, game audio, game animation, virtual reality, digital entertainment, PC game, Xbox game, game news, new game, arcade development, Nintendo development, Playstation development, Playstation 2, PS2, Dreamcast development, Game Developer magazine, Computer Game Developers Conference, Game Developers Conference, Independent Game Developers Conference, CMP Game Media Group, game industry research, online game development, digital assets, free textures, free 3D models, free shaders, Gamasutra Exchange, 3D Studio Max textures" /><meta name="description" content="Fullscreen exclusive is real, but I haven't been able to find a single game where the fullscreen exclusive vs borderless window settings do what you'd" />
		<!--[if lt IE 9]>
		<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->
	<style>
		
			.cke_source{
				white-space:normal !important;
			}
			.hide_phone > iframe {
				width: 100%;
			}
			@media only screen and (max-width:479px){
				.hide_phone > iframe {
					height: auto;
				}
				.embeddedContent iframe, .page_data_1 iframe {
					width: 100%;
				}
			}
			.properties ul li {
				padding: 5px 28px !important;
			}
			.formElement label.questionLabel p.description {
				font-weight: normal;
				padding: 0 !important;
			}
			div#rightlinks ul {
				padding: 0 15px !important;
			}
			.article img {
				max-width: 100% !important;
			}
			@media screen and (max-width: 425px) {
				blockquote{
					float:none !important;
					clear:both;
				}
			}
		

	</style>
	<!-- CSS -->
        
        
<meta property="fb:app_id" content="1424004174373289"/>		
        			 <meta property="og:type" content="article"/>
			 <meta property="og:url"  content="https://gamasutra.com/blogs/MasonRemaley/20210222/377715/Fullscreen_Exclusive_Is_A_Lie_sort_of.php" />
			 <meta property="og:title" content="Fullscreen Exclusive Is A Lie (...sort of)" />
                   	 	
                                <meta name="og:image" content="https://gamasutra.com/blogs/edit/img/portrait/1030304/portrait.jpg" />
                         			 <meta property="og:description" content="Fullscreen exclusive is real, but I haven't been able to find a single game where the fullscreen exclusive vs borderless window settings do what you'd expect." />
				
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:site" content="@gamasutra" />
		<meta name="twitter:creator" content="@gamasutra" />
					<meta name="twitter:title" content="Fullscreen Exclusive Is A Lie (...sort of)" />
			<meta name="twitter:description" content="Fullscreen exclusive is real, but I haven't been able to find a single game where the fullscreen exclusive vs borderless window settings do what you'd expect." />
			<meta name="twitter:creator" content="@gamasutra" />
			<meta name="twitter:url" content="https://gamasutra.com/blogs/MasonRemaley/20210222/377715/Fullscreen_Exclusive_Is_A_Lie_sort_of.php" />
			<meta name="twitter:image" content="https://gamasutra.com/blogs/edit/img/portrait/1030304/portrait.jpg" />
		
        
                	<link rel="canonical" href="https://gamasutra.com/blogs/MasonRemaley/20210222/377715/Fullscreen_Exclusive_Is_A_Lie_sort_of.php" />
                <link rel="alternate" type="application/rss+xml" title="Gamasutra Article Feed" href="https://feeds.feedburner.com/GamasutraFeatureArticles/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra News Feed" href="https://feeds.feedburner.com/GamasutraNews/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Columns Feed" href="https://feeds.feedburner.com/GamasutraColumns/" />
        <link rel="alternate" type="application/rss+xml" title="Gamasutra Jobs Feed" href="https://feeds.feedburner.com/GamasutraJobs/" />
        <!-- link href="https://twimgs.com/gamasutra/css/minified.css" rel="stylesheet" type="text/css" / -->
        <link href="https://twimgs.com/nojitter/gama/css/gama_unminified.css?v1" rel="stylesheet" type="text/css" />
		<style>
			
				#div-gpt-ad-Ltile1 {
					margin-top: 10px;
				}
			
		</style>
        
                         <meta name="node" content="Gama1"/>
            
        <meta name="pagecaching" content="332"/>
        		<script language="JavaScript" type="text/javascript" src="https://twimgs.com/custom/library.gtecevent.com/assets/VisitorAPI.js?ormzkk"></script>
    <script type="text/javascript" src="https://twimgs.com/custom/library.gtecevent.com/assets/at.js?ormzkk"></script>
        <script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/redesign_comments.js"></script>
		<script src="//code.jquery.com/jquery-1.8.2.min.js"></script>
		<script type="text/javascript" async src="https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.5/MathJax.js?config=TeX-MML-AM_CHTML"></script>
    <script type="text/javascript" src="https://twimgs.com/gamasutra/js/combined.js"></script>
    <script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/nextgengama.js?v5"></script>
    <script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/checkauth.js?v11"></script>
		<script type="text/javascript"> 
        
		function checkMail(obj){
	 
		   var think_opt_out = document.getElementById('Think_Opt_Out');
	 
		   if (document.getElementById('Think_Opt_Out').checked) {
	 
				 document.getElementById('Think_Opt_In').value = 0;
		   } else {
	 
				 document.getElementById('Think_Opt_In').value = 1;
		   }
		   var firstname = document.getElementById('firstname').value;
		   if (firstname == ""){
				 alert('Please provide your first name');
				 return false;
		   }
	 
		   if (document.getElementById('lastname').value == ''){
				 alert("Please provide your lastt name");
				 return false;
		   }
	 
	 
		   var x = document.getElementById('EmailAddr').value;
	 
		   var filter  = /^([a-zA-Z0-9_\.\-])+\@(([a-zA-Z0-9\-])+\.)+([a-zA-Z0-9]{2,4})+$/;
		   if (filter.test(x)) { return true; }
		   else  { alert('Invalid Email Address detected. Please correct.'); return false; }
	 
	 
		}
		 
		</script>
        <script type="text/javascript" src="https://twimgs.com/gamasutra/js/md5.js"></script>

        

        <script type="text/javascript">
        var adrand = parseInt(Math.random()*1000000000, 10);
        var adkeys = "key1+key2+key3+key4";
        </script>

        	<!-- Mobile Specific Metas -->
	<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" /> 
	
	<script type="text/javascript">
            
		var browser			= navigator.userAgent;
		var browserRegex	= /(Android|BlackBerry|IEMobile|Nokia|iP(ad|hone|od)|Opera M(obi|ini))/;
		var isMobile		= false;
		if(browser.match(browserRegex)) {
			isMobile			= true;
			
		}
        
	</script>
        <!-- Start Visual Website Optimizer Asynchronous Code -->
        <script type='text/javascript'>
        
        var _vwo_code=(function(){
        var account_id=32069,
        settings_tolerance=2000,
        library_tolerance=2500,
        use_existing_jquery=false,
        // DO NOT EDIT BELOW THIS LINE
        f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
        
        </script>
        <!-- End Visual Website Optimizer Asynchronous Code -->
       
        
        <!-- Start HeatMap.me Code -->
		<script type='text/javascript'>
		(function(h,e,a,t,m,p)
		{ m=e.createElement(a);m.async=!0;m.src=t; p=e.getElementsByTagName(a)[0];p.parentNode.insertBefore(m,p); }
		)(window,document,'script','https://u.heatmap.it/log.js');
		</script>
		<!-- End HeatMap.me Code -->
        
        
				
		<!-- Start: GPT Sync -->
        <script>
		
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        googletag.slots = googletag.slots || {};
        var gptadslots=[];
		
        </script>
        <script src="//www.googletagservices.com/tag/js/gpt.js"></script>

        <script type="text/javascript">
              
                      googletag.pubads().setTargeting('kw',['programming','console-pc','indie']);
                                            googletag.pubads().setTargeting('aid',['377715']);
          		
				if (document.documentElement.clientWidth > 767)
				{
				//Adslot 19 declaration
		
					gptadslots[19]=googletag.defineSlot('/3834/gamasutra.home/consolepc',[[2,2]],'div-gpt-ad-welcome').setTargeting('pos',['welcome']).setTargeting('testAd',['']).addService(googletag.pubads());
		
				}
				else
				{
				//Adslot 20 declaration
		
					gptadslots[20]=googletag.defineSlot('/3834/gamasutra.home/consolepc',[[7,7]],'div-gpt-ad-mi').setTargeting('pos',['mi']).setTargeting('testAd',['']).addService(googletag.pubads());
		
				}
				  
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		
					gptadslots[1]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[1,2]],'div-gpt-ad-skin').setTargeting('pos',['skin']).setTargeting('testAd',['']).addService(googletag.pubads());

					gptadslots[2]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[728,90]],'div-gpt-ad-top').setTargeting('pos',['top']).setTargeting('testAd',['']).addService(googletag.pubads());
		
				}else{ 
		
					gptadslots[13]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[300,50]],'div-gpt-ad-mobile_leaderboard').setTargeting('pos',['mobile_leaderboard']).setTargeting('testAd',['']).addService(googletag.pubads());
		

		}
		            
          //Adslot 1 declaration
       

				  //Adslot 2 declaration
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 3 declaration
					 gptadslots[3]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[164,59]],'div-gpt-ad-button1').setTargeting('pos',['button1']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 4 declaration
					 gptadslots[4]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[164,59]],'div-gpt-ad-button2').setTargeting('pos',['button2']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 5 declaration
					 gptadslots[5]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[164,409]],'div-gpt-ad-callout').setTargeting('pos',['callout']).setTargeting('testAd',['']).addService(googletag.pubads());
		

				}
		
						
			//Adslot 6 declaration
			gptadslots[6]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[300,250]],'div-gpt-ad-rec1').setTargeting('pos',['rec1']).addService(googletag.pubads());
						
		
				if (document.documentElement.clientWidth > 767){//Adslot 3 declaration
		

					 //Adslot 7 declaration
					 gptadslots[7]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[160,600]],'div-gpt-ad-sky1').setTargeting('pos',['sky1']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 8 declaration
					 gptadslots[8]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[160,160]],'div-gpt-ad-Ltile1').setTargeting('pos',['Ltile1']).setTargeting('testAd',['']).addService(googletag.pubads());

					 //Adslot 9 declaration
					 gptadslots[9]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[164,177]],'div-gpt-ad-custom1').setTargeting('pos',['custom1']).setTargeting('testAd',['']).addService(googletag.pubads());

					
					 //Adslot 11 declaration
					 gptadslots[11]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[164,177]],'div-gpt-ad-custom3').setTargeting('pos',['custom3']).setTargeting('testAd',['']).addService(googletag.pubads());
					  
          
		
		}
		
		 gptadslots[14]= googletag.defineSlot('/3834/gamasutra.home/consolepc', [[3,3]],'div-gpt-ad-ribbon').setTargeting('pos',['ribbon']).setTargeting('testAd',['']).addService(googletag.pubads());
		 		 		 													//Adslot 21 declaration
			gptadslots[21]=googletag.defineSlot('/3834/gamasutra.home/consolepc',[[8,2]],'div-gpt-ad-native').setTargeting('pos',['native']).setTargeting('testAd',['']).addService(googletag.pubads());
			//Adslot 22 declaration
			gptadslots[22]=googletag.defineSlot('/3834/gamasutra.home/consolepc',[[8,4]],'div-gpt-ad-insight').setTargeting('pos',['insight']).setTargeting('testAd',['']).addService(googletag.pubads());
			//Adslot 23 declaration
			gptadslots[23]=googletag.defineSlot('/3834/gamasutra.home/consolepc',[[4,4]],'div-gpt-ad-video').setTargeting('pos',['video']).setTargeting('testAd',['']).addService(googletag.pubads());
		

         googletag.pubads().enableSingleRequest();
		 googletag.pubads().collapseEmptyDivs();
         		 googletag.pubads().enableAsyncRendering();
         googletag.enableServices();
        </script>
        <!-- End: GPT -->
	
	<script type="text/javascript">
	
	  var _AdsNativeOpts =
	  {
	
		keywords: ['consolepc']
	
	  };
	
	</script>
        
         		<script type="text/javascript">
 		
			var _gaq = _gaq || [];
			_gaq.push(['_setAccount', 'UA-48094207-1']);
			_gaq.push(['_trackPageview']);
			(function()
			{ var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true; ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s); }
			)();
		
		</script>
		<link rel="stylesheet" href="https://i.ubm-us.net/oas/nativead/css/game_nativead.css" />
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/nativead.js"></script>
		<script language="JavaScript" src="https://i.ubm-us.net/oas/nativead/js/game_nativead.js"></script>
		<link rel="stylesheet" href="https://twimgs.com/nojitter/gama/css/informa-iribbon.css" />
	<script src="https://twimgs.com/nojitter/gama/js/informa-iribbon.js"></script>
	<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/cookie_banner.js"></script>
	<link rel="stylesheet" href="https://img.deusm.com//darkreading/cookie_banner_css.css" />
	
<!-- Eloqua tracking code -->
<script type='text/javascript' language='JavaScript'>
var _elqQ = _elqQ || [];
_elqQ.push(['elqSetSiteId', '2150']);
_elqQ.push(['elqUseFirstPartyCookie', 'trk.gamasutra.com']);
_elqQ.push(['elqTrackPageView']);

(function () {
function async_load() {
    var s = document.createElement('script'); s.type = 'text/javascript'; s.async = true;
    s.src = '//img.en25.com/i/elqCfg.min.js';
    var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
}
if (window.addEventListener) window.addEventListener('DOMContentLoaded', async_load, false);
else if (window.attachEvent) window.attachEvent('onload', async_load); 
})();
</script>
<!-- End Eloqua tracking code -->	
</head>
<body >
  <!-- Google Tag Manager (noscript) -->
  <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NDKS786" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
  <!-- End Google Tag Manager (noscript) -->
	<!--Cookie banner code starts here -->
	<div id="gdpr_banner" style="display:none;">
	<div id = "cookie">
	<div class="gdpr-popup-border">
	<div class="gdrp-popup-content">
		<div id="popup-text">This site uses cookies to provide you with the best user experience possible. By using Gamasutra, you accept <a href="https://tech.informa.com/cookie-policy" target="_blank">our use of cookies.</a></div>
		<div id="popup-buttons"><span class="close-button" >&times;</span></div>
	</div>
	</div>
	</div>
	</div>
	<!--Cookie banner code ends here -->
	<!-- Informa Branding code goes here-->
	<div id="iribbon-container" class="content-body-wrapper" style="padding-top:10px; opacity:0;">
			<button id="iribbon-title" title="show/hide" class="inactive">Informa</button>
			<div id="iribbon-detail" class="ribbon-hide" style="">
    		<div id="iribbon-left">
        		<p>Gamasutra is part of the Informa Tech Division of Informa PLC</p>
        		<ul>
            		<li class="iribbon-mainlink"><a href="https://informa.com/" tabindex="-1" class='iribbon-opacity-out'>Informa PLC</a></li>
            		<li><a href="https://informa.com/About-Us/" tabindex="-1" class='iribbon-opacity-out'>About us</a></li>
            		<li><a href="https://informa.com/Investors/" tabindex="-1" class='iribbon-opacity-out'>Investor relations</a></li>
            		<li><a href="https://informa.com/Talent/" tabindex="-1" class='iribbon-opacity-out'>Talent</a></li>
        		</ul>
    		</div>
    			<div id="iribbon-right">
        			<p>This site is operated by a business or businesses owned by Informa PLC and all copyright resides with them. Informa PLC's registered office is 5 Howick Place, London SW1P 1WG. Registered in England and Wales. Number 8860726.</p>
    			</div>
			</div>
	</div>
	<!-- Informa Branding code goes here-->
	<!-- Beginning Sync AdSlot 19 for Ad unit Gamasutra//consolepc ### size: [[2,2]]  -->
<div id='div-gpt-ad-welcome'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-welcome');
	}
	);
 </script>
</div>
<!-- End AdSlot 19 -->
	<!-- Beginning Sync AdSlot 20 for Ad unit Gamasutra//consolepc ### size: [[7,7]]  -->
<div id='div-gpt-ad-mi'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-mi');
	}
	);
 </script>
</div>
<!-- End AdSlot 20 -->
    <div class="hide-phone">
                                <!-- Beginning Sync AdSlot 1 for Ad unit Gamasutra//consolepc ### size: [[1,2]]  -->
<div id='div-gpt-ad-skin'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-skin');
	}
	);
 </script>
</div>
<!-- End AdSlot 1 -->
            </div>
	
	<div class="container"> 
	<div id="container-main" class="content-body-wrapper" style="opacity:0;">
	<script src="/prestitial/adblockDetector.js"></script>
	<!-- Google Prestitial Ads start here-->
	<script>
	  
	  var isblocked = "notblocked";
	  if(!document.getElementById('xRokYeIsHL')){
	   isblocked = "blocked";
	  }
	  console.log('lpage==>' + isblocked);
	  if (isblocked == "notblocked") {
		setTimeout(function() {
		console.log('5 second timeout ');
		unhideMainContent();
		}, 5000);
		googletag.pubads().addEventListener('slotRenderEnded', function(event) {
		  if(event.slot.getSlotElementId() == "div-gpt-ad-welcome")
			{
			console.log('interstitial unit found');
			if(event.isEmpty) {
			  console.log('empty Interstitial');
			   unhideMainContent();
			}
			else {
			  console.log('not empty Interstitial');
			}
		  }
		});
		googletag.enableServices();
	  }else{
		  unhideMainContent();
	  }
	function unhideMainContent() {
		console.log('unhide main content');
		var bDiv = document.getElementsByClassName("content-body-wrapper");

		for (var i=0; i<bDiv.length; i++) {
		  if(bDiv[i].style.removeProperty) {
		   bDiv[i].style.removeProperty('opacity');
		  } 
		  else {
			bDiv[i].style.removeAttribute('opacity');
		  }
		}
	}
	
	</script>
	<!-- Google  Prestitial Ads end here-->
	
    <div class="hide-phone">
         <div class="wrapper properties">
            
		
         </div><!--end wrapper-->
    </div>
    
    <br />
     <div class="container bottom3">
     	<div class="span-7">
          	<a href="https://gamasutra.com"><img src="https://twimgs.com/gamasutra/images/gamasutra_logo.png" alt="Gamasutra: The Art &amp; Business of Making Games" width="243" height="77" border="0" /></a><img alt="spacer" src="https://twimgs.com/gamasutra/images/spacer.gif" width="27" />
		</div>
          <div class="hide-phone">
              <div class="div span-16 last leaderboard">
                     
                                                                               <!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra//consolepc ### size: [[728,90]]  -->
<div id='div-gpt-ad-top'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-top');
	}
	);
 </script>
</div>
<!-- End AdSlot 2 -->
                                           
    
              </div>
          </div>
    </div>

		<div class="span-20">
			<div class="show-phone clearfix" style="padding:0px 0 5px 0"><!--sadie change-->
                        <div class="span-5 center ">
								<!-- Beginning Sync AdSlot 2 for Ad unit Gamasutra//consolepc ### size: [[300,50]]  -->
<div id='div-gpt-ad-mobile_leaderboard'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-mobile_leaderboard');
	}
	);
 </script>
</div>
<!-- End AdSlot 2 -->

                        </div>
				</div>

                    <div class="show-phone"><!--there is another on the page for the regular size, this is phone only-->
                         <div class="span-5 last nav_search">
                              <div class="content center">
                                   <span class="nav_searchtxt">SEARCH</span>
                                   <form class="left" name="topsearchph" action="/search/" method="GET">
          
                                               <input name="search_text" type="text" size="25" class="search" />	  
                                              <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearchph.submit(); return false;">GO</a></span>
                                   
                                   </form>
                              </div>
                         </div>
                    </div><!--end show phone-->
                    
                    <div class="show-phone"><!--sadie change-->
                        <div class="span-3">
                                  <div class="login_phone" id="login_phone">
                                       
                                   </div>
                        </div>
                    </div><!--end showphone-->
                    <div class="nav">
                	<div class="span-3 nav_jobs">
                    	<div class="content">
                              <a href="https://jobs.gamasutra.com/">GAME JOBS</a>
                          </div>
                    </div>
                    <div class="span-12 nav_links">
                         <div class="content">
                                   <a href="/updates/">updates</a>
                                   <a href="/blogs/">Blogs</a>
                                   
                                   <a href="/contractors/contractor_display.php">contractors</a>
                                   <a href="/newsletter-signup">newsletter</a>
                                   <a target="_blank" href="https://www.gamecareerguide.com" style="color:#664271;">Game Career Guide</a>
                         </div>
                    </div>
                    <div class="hide-phone">
                        <div class="span-5 last nav_search">
                             <div class="content">
                                  <span class="nav_searchtxt">SEARCH</span>
                                  <form class="left" name="topsearch" action="/search/" method="GET">

                                              <input name="search_text" type="text" size="10" class="search" />	  
                                             <span class="nav_searchbutton"><a href="" onClick="javascript: document.topsearch.submit(); return false;">GO</a></span>

                                    </form>
                             </div>
                        </div>
                    </div>
                    <br class="clear">
               </div><!--end nav-->
               <div class="hide-phone"> 
                    <div class="span-20 last"> 
                       <div class="topicmenu">
                            <ul>
                                <li class="activetab"><a href="https://gamasutra.com">ALL</a>
                                </li><li ><a href="/topic/console-pc">CONSOLE/PC</a>
                                </li><li ><a href="/topic/smartphone-tablet">SMARTPHONE/TABLET</a>
                                </li><li ><a href="/topic/indie">INDEPENDENT</a>
                                </li><li ><a href="/topic/vr">VR/AR</a>
                                </li><li ><a href="/topic/social-online">SOCIAL/ONLINE</a>
                                </li></ul>
                                                          <span class="gdmag"><a href="/resourcecenter"><img src="https://twimgs.com/nojitter/gama/image/btn_gdmag1.png" width="118px" height="33px"></a></span>
                       </div>
                   </div>
               </div>		
                    <div class="span-20 last content_bg">
                        <div class="hide-phone">
<div class="span-4">
  <div class="content_box_left">
    <div class="leftcol">
        <!--member login-->
                    <table width="166" border="0" cellspacing="0" cellpadding="0">
  <tr>
    <td id="memberLogin" class="welcome">
    </td>
  </tr>
</table>                 <!--end memberlogin-->
        
        <!--begin social icons-->
            <!--begin social icons-->
<div  class="bottom2">
    <ul class="leftcol_social">
       <li class="facebook"><a href="https://www.facebook.com/pages/Gamasutra/31610613408" target="_blank">&nbsp;</a></li>
       <li class="twitter"><a href="https://twitter.com/gamasutra" target="_blank">&nbsp;</a></li>
       <li class="feed"><a href="https://gamasutra.com/static2/rssfeeds.html">&nbsp;</a></li>
       <li class="newsletter"><a href="/newsletter-signup">&nbsp;</a></li>
    </ul>
</div>
<!--end social icons-->        <!--end social icons-->
        
        <!--begin page numbers-->
                <!--end page numbers-->
        
        <!--begin leftnav-->
                <div class="leftnav_categories bottom2">
   <a href="/category/programming/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_programming.gif"  width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/programming/">PROGRAMMING</a></div>

   <hr>

   <a href="/category/art/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_art.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/art/">ART</a></div>

   <hr>

   <a href="/category/audio/"><img alt="spacer" src="https://twimgs.com/gamasutra/images/button_audio.gif" width="24px" height="24px"  /></a>         
   <div class="leftnav_btn"><a href="/category/audio/">AUDIO</a></div>

   <hr>

   <a href="/category/design/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_design.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/design/">DESIGN</a></div>

   <hr>

   <a href="/category/production/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_production.gif" width="24px" height="24px" /></a>
   <div class="leftnav_btn"><a href="/category/production/">PRODUCTION</a></div>

   <hr>
   <a href="/category/business-marketing/"><img alt="arrow" src="https://twimgs.com/gamasutra/images/button_business.gif" width="24px" height="24px"  /></a>
   <div class="leftnav_btn"><a href="/category/business-marketing/">BIZ/MARKETING</a></div>

   <br class="clear">
</div>          <!--end leftnav-->
                  
                    <!-- Beginning Sync AdSlot 3 for Ad unit Gamasutra//consolepc ### size: [[164,59]]  -->
<div id='div-gpt-ad-button1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-button1');
	}
	);
 </script>
</div>
<!-- End AdSlot 3 -->
            <!-- Beginning Sync AdSlot 4 for Ad unit Gamasutra//consolepc ### size: [[164,59]]  -->
<div id='div-gpt-ad-button2'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-button2');
	}
	);
 </script>
</div>
<!-- End AdSlot 4 -->
            <!-- Beginning Sync AdSlot 5 for Ad unit Gamasutra//consolepc ### size: [[164,409]]  -->
<div id='div-gpt-ad-callout'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-callout');
	}
	);
 </script>
</div>
<!-- End AdSlot 5 -->
            <!-- Beginning Sync AdSlot 9 for Ad unit Gamasutra//consolepc ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-custom1');
	}
	);
 </script>
</div>
<!-- End AdSlot 9 -->
            <!-- Beginning Sync AdSlot 11 for Ad unit Gamasutra//consolepc ### size: [[164,177]]  -->
<div id='div-gpt-ad-custom3'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-custom3');
	}
	);
 </script>
</div>
<!-- End AdSlot 11 -->
                
        <!-- begin event tickers -->
			              
        <!-- end event tickers -->
	
         <!--begin jobs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_jobs.png" width="22px" height="20px"/><a href="https://jobs.gamasutra.com/">Latest Jobs</a></div>
<div class="leftnav bottom2">
     <a href="https://jobs.gamasutra.com/"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp;
     <a href="https://feeds.feedburner.com/GamasutraJobs"><strong>RSS</strong></a>
     <hr>
     <strong>July  1, 2021</strong>
     <hr>
     <ul>    
            <li>Xbox Graphics<br />
              <a href="https://jobs.gamasutra.com/job/senior-software-engineer-performance-tooling-redmond-washington-35125">Senior Software Engineer: Performance Tooling</a>
        </li>
        <li class="line"></li>
            <li>Xbox Graphics<br />
              <a href="https://jobs.gamasutra.com/job/senior-software-engineer-gpu-compilers-redmond-washington-35124">Senior Software Engineer: GPU Compilers</a>
        </li>
        <li class="line"></li>
            <li>Aardman Animations Ltd <br />
              <a href="https://jobs.gamasutra.com/job/experienced-technical-artist-games-bristol-england-35121">Experienced Technical Artist (Games) </a>
        </li>
        <li class="line"></li>
            <li>Aardman Animations Ltd <br />
              <a href="https://jobs.gamasutra.com/job/lead-engineer-games-bristol-england-35120">Lead Engineer (Games) </a>
        </li>
        <li class="line"></li>
            <li>SideFX<br />
              <a href="https://jobs.gamasutra.com/job/senior-distributed-systems-developer-toronto-ontario-35072">Senior Distributed Systems Developer</a>
        </li>
        <li class="line"></li>
            <li>Treyarch / Activision<br />
              <a href="https://jobs.gamasutra.com/job/ui-engineer-santa-monica-california-35108">UI Engineer </a>
        </li>
        <li class="line"></li>
         </ul>    
</div>
         <!--end jobs-->   
           			
         <!--begin blogs-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/><a href="/blogs/">Latest Blogs</a></div>
<div class="leftnav bottom2">
    <a href="/blogs/"><strong>View All</strong></a> 
    &nbsp;&nbsp;&nbsp; <a href="/blogs/edit/"><strong>Post</strong></a>
    &nbsp;&nbsp;&nbsp; <a href="/blogs/rss/"><strong>RSS</strong></a>
    <hr>
    <strong>July  1, 2021</strong>
    <hr>   
    <ul>
        
        <li>
            <a href="/blogs/SimonCarless/20210630/384414/SNKRX_anatomy_of_a_sleeper_hit.php">SNKRX: anatomy of a sleeper hit</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/WendelinReich/20210630/384246/The_future_of_interactive_characters_part_24_What_makes_behavior_quotbelievablequot.php">The future of interactive characters, part 2/4: What makes behavior &quot;believable&quot;?</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/ChelseaBlasko/20210629/384305/Iron_Galaxy_Celebrates_Pride_as_we_Welcome_a_New_DEI__Access_Program_Manager.php">Iron Galaxy Celebrates Pride as we Welcome a New DEI & Access Program Manager</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/WendelinReich/20210629/384202/The_future_of_interactive_characters_part_14_Twelve_basic_principles_of_behavior.php">The future of interactive characters, part 1/4: Twelve basic principles of behavior</a>
                    </li>
        <li class="line"></li>
        
        <li>
            <a href="/blogs/PascalLuban/20210629/384211/Battlefield_2042__Should_the_game_industry_follow_the_footsteps_of_Hollywood.php">Battlefield 2042 - Should the game industry follow the footsteps of Hollywood?</a>
                    </li>
        <li class="line"></li>
       
    </ul>
</div>
         <!--end blogs-->
         
         <!--begin press releases-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png" width="22px" height="20px"/>Press Releases</div>
<div class="leftnav bottom2">
    <strong>July  1, 2021</strong>
	<hr>
	       <a href="/pressreleases_index.php"><strong>Games Press</strong></a>
   <hr>
   <ul>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/384442/Independent_UK_Esports_Team_Committee_formed.php">Independent UK Esports
Team Committee formed</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/384438/SANDBOX_MMO_MORTAL_ONLINE_2_INTRODUCES_NEW_AI_PVE_ENEMIES_A_NEW_DUNGEON__CHARACTER_TATTOOS.php">SANDBOX MMO MORTAL ONLINE
2 INTRODUCES NEW AI,
PVE...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/384439/WEBZEN_introduces_Shot_Online_Golf_Battle_available_to_preregister_for_both_Android_and_iOS.php">WEBZEN introduces Shot
Online: Golf Battle,...</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/384431/Odders_brings_Chess_Club_to_the_Quest_Store.php">Odders brings Chess Club
to the Quest Store</a>
        </li>
        <li class="line"></li>
          
        <li>
            <a href="https://gamasutra.com/view/pressreleases/384432/Affectus_has_been_nominated_for_the_Fan_Favorite_Vote_15_at_GDWC_2021.php">Affectus has been
nominated for the Fan
Favorite...</a>
        </li>
        <li class="line"></li>
         </ul>
   <a href="/pressreleases_index.php"><strong>View All</strong></a> 
   &nbsp;&nbsp;&nbsp; <a href="/pressreleases/rss/"><strong>RSS</strong></a>
</div>         <!--end press releases-->
                         
         <!--begin calendar-->
            <!--

<div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_calendar.png" width="22px" height="20px"/><a href="http://gamasutra.com/calendar/calendar.php">Calendar</a></div>
<div class="leftnav bottom2">
    <a href="http://gamasutra.com/calendar/calendar.php"><strong>View All</strong></a> &nbsp;&nbsp;&nbsp; <a href="http://gamasutra.com/calendar/calendar_submit.php"><strong>Submit Event</strong></a>
    <hr>
    <ul>
        
    </ul>
</div>

-->         <!--end calendar-->
                         
         <!--begin about-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="/contactus">About</a></div>
<div class="leftnav bottom2">
    <ul>
            <li><strong>Editor-In-Chief: </strong><br /><a href="/cdn-cgi/l/email-protection#81eae6f3e0e7f5c1e6e0ece0f2f4f5f3e0afe2eeec">Kris Graft</a></li>
            <li class="line"></li>
            
            <li><strong>News Editor: </strong><br /> <a href="/cdn-cgi/l/email-protection#4a2b262339392b6427292b262525240a3f282764292527">Alissa McAloon</a></li>
            <li class="line"></li>
            
            <li><strong>Contributors: </strong><br />
				Chris Kerr<br />
				Bryant Francis<br />
				Katherine Cross<br />
			</li>	
            <!--<li><strong>Advertising: </strong><br /><a href="mailto:sales@gamasutra.com?subject=Request%20Info:%20Gamasutra">sales@gamasutra.com</a></li>-->
    </ul>
    <hr>
    <div class="center"><a href="/contactus">Contact Gamasutra</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#54272124243b2620143335393527212026357a373b39">Report a Problem</a></div>
    <hr>
    <div class="center"><a href="/cdn-cgi/l/email-protection#82ece7f5f1c2e5e3efe3f1f7f6f0e3ace1edef">Submit News</a></div>
    <hr>
    <div class="center"><a href="/static2/comment_guidelines.html">Comment Guidelines</a></div>
    <hr>
    <div class="center"><a href="/static2/blogsubmissions.html">Blogging Guidelines</a></div>
    <hr>
    <div class="center"><a href="/static2/howwework.html">How We Work</a></div>
	<!--<hr>
	<div class="center"><a href="/advertise">Advertise with Gamasutra</a></div>-->
	<hr>
    <div class="center"><a href="https://reg.gdconf.com/gama-media-kit">Download Media Kit</a></div>
</div>

<div class="bottom2">
    <a href="/advertise">
        <img src="https://twimgs.com/gamasutra/images/AdwGama_177x60_button_v1.jpg" alt="Sponsor" border="0" class="whiteTop"  width="177px" height="60px"/>
    </a>
</div>
             <!--end about-->
         
         <!--begin network-->
            <div class="header"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_about.png" width="22px" height="20px"/><a href="#">Gama Network</a></div>
<div class="leftnav_network bottom2">
    If you enjoy reading this site, you might also want to check out these UBM Tech sites:
    <hr>
    <a href="https://www.gamecareerguide.com"><!-- img src="http://www.indiegames.com/blog/gcgmini.jpg" align="left" hspace="2"/ --></a> 
    <div class="leftnav_btn"><a href="https://www.gamecareerguide.com">Game Career Guide</a></div>
    <hr>
    <a href="https://www.indiegames.com/blog"><!-- img src="http://www.indiegames.com/blog/indiemini.jpg" align="left" hspace="2"/ --></a>
    <div class="leftnav_btn"><a href="https://www.indiegames.com/blog">Indie Games</a></div>
    <br class="clear">
</div>         <!--end network-->
         
         <!--begin store-->
                     <!--end store-->
         
                
    </div><!--end leftcol-->
  </div>
</div> 
</div>  	<style>.content_box_middle pre {
		overflow-x:auto;
	}
	.item_title{
		    margin-top: 0px !important;
			margin-bottom: 0px !important;
	}
	</style>
<div class="span-16 last">
    <div class="content_box_middle">
        <!-- InstanceBeginEditable name="BodyContent" --> 
        <div class="header_large">
            <span class="left"><img alt="arrow" src="https://twimgs.com/gamasutra/images/icon_blogs.png"/><a href="/blogs/">Blogs</a></span>
        </div>
        <div class="page_item"> 
                        <div class="clear">&nbsp;</div>
            <h1 class="item_title">Fullscreen Exclusive Is A Lie (...sort of)</h1>
            <div>
                <span class="newsAuth">by <a href="/blogs/author/MasonRemaley/1030304/">Mason Remaley</a> on 02/22/21 10:58:00 am 
                                        &nbsp; <img valign="bottom" border="0" src="https://twimgs.com/gamasutra/images/featuredIcon_gamaBlog.gif" alt="Featured Blogs" />                                        <br />
                </span>
            </div>
            <div>
                <br>
                                    <span class="comment_text">
                                                    <a href="#comments">Post A Comment</a>
                                            </span>
                    <a name="twitter_share" type="button" href="http://twitter.com?status=RT @gamasutra: Fullscreen Exclusive Is A Lie (...sort of) http://www.gamasutra.com/blogs/MasonRemaley/20210222/377715/" target="_blank"><img src="https://twimgs.com/gamasutra/images/twitter.gif" alt="Share on Twitter" border="0" height="20"/></a>
                    <iframe src="https://www.facebook.com/plugins/share_button.php?href=https://www.gamasutra.com/blogs/MasonRemaley/20210222/377715/&layout=button&size=large&mobile_iframe=true&width=72&height=28&appId" width="72" height="28" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true"></iframe>

                    <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
                    <g:plusone size="medium" count="false"></g:plusone>
					<span id="edit_post_link"></span>&nbsp;&nbsp;
					<a href="/blogs/rss/"><img src="https://twimgs.com/gamasutra/images/icon_rss.gif" width="15" height="15" border="0" alt="RSS" /></a>
                            </div>
            <hr>
            <div class="item_body mobile_image_transform">       
                <strong><i><small>
                    The following blog post, unless otherwise noted, was written by a member of Gamasutra&#146;s community.<br />
					The thoughts and opinions expressed are those of the writer and not Gamasutra or its parent company.                </small></i></strong>
                <hr>
                <div class="clear">&nbsp;</div>
                <h1>Fullscreen Exclusive Is A Lie (...sort of)</h1>

<p><img alt="way of rhea video settings" height="318" src="https://www.anthropicstudios.com/assets/monsters-and-sprites/fullscreen-exclusive-is-a-lie/settings.png" width="587" /></p>

<p>Fullscreen exclusive is a real thing your computer can decide to grant a window, but, as of yet I haven&#39;t been able to find a single game where the fullscreen exclusive vs borderless window settings do what you&#39;d expect them to.</p>

<p>If you&#39;re an expert in this topic and believe this post is incorrect in any way, definitely <a href="/cdn-cgi/l/email-protection#acc1cddfc3c282dec9c1cdc0c9d587dcd9ceeccbc1cdc5c082cfc3c1">email me</a> or <a href="https://twitter.com/masonremaley">DM me on Twitter</a> and I&#39;ll issue a correction!</p>

<p>If you&#39;re interested in jumping to the conclusion, see <a href="#testing-fullscreen-exclusivity-in-other-games">Testing Fullscreen Exclusivity in Other Games</a> and <a href="#takeaways">Takeaways</a>. If you&#39;re interested in my methodology, read on.</p>
<!--more-->

<h1>Table of Contents</h1>

<ul>
	<li><a href="#table-of-contents">Table of Contents</a></li>
	<li><a href="#defining-our-terms">Defining Our Terms</a></li>
	<li><a href="#resolutions--scaling">Resolutions &amp; Scaling</a></li>
	<li><a href="#methods-of-enabling-fullscreen-exclusive-mode-in-opengl">Methods of Enabling Fullscreen Exclusive Mode in OpenGL</a></li>
	<li><a href="#testing-if-were-fullscreen-exclusive">Testing If We&#39;re Fullscreen Exclusive</a>
	<ul>
		<li><a href="#tests-that-dont-work">Tests That Don&#39;t Work</a>
		<ul>
			<li><a href="#volume-meter">Volume Meter</a></li>
			<li><a href="#windows-key">Windows Key</a></li>
			<li><a href="#flashing">Flashing</a></li>
		</ul>
		</li>
		<li><a href="#a-test-that-works">A Test That Works</a></li>
	</ul>
	</li>
	<li><a href="#testing-methods-of-gaining-fullscreen-exclusivity-in-opengl">Testing Methods of Gaining Fullscreen Exclusivity in OpenGL</a></li>
	<li><a href="#testing-fullscreen-exclusivity-in-other-games">Testing Fullscreen Exclusivity in Other Games</a></li>
	<li><a href="#takeaways">Takeaways</a></li>
</ul>

<h1 id="defining-our-terms">Defining Our Terms</h1>

<p>Today I&#39;m specifically discussing Windows 10. I&#39;m using OpenGL and calling into win32 directly, but these results will likely be of interest regardless of your graphics API and windowing library. I should probably define some terms before we start:</p>

<ul>
	<li>When I say fullscreen exclusive, I&#39;m referring to a fullscreen window that bypasses the compositor.</li>
	<li>I&#39;m aware that there&#39;s technically a distinction between <a href="https://devblogs.microsoft.com/directx/demystifying-full-screen-optimizations/">full screen optimizations mode</a> and fullscreen exclusive, but I&#39;m not particularly concerned about that difference. I ran a number of these tests with FSO disabled and saw no discernible difference.</li>
</ul>

<p>It&#39;s also worth noting, most games that have a fullscreen exclusive option will mess with your display&#39;s resolution when it&#39;s enabled. Whether or not changing your display settings is <em>necessary</em> for exclusivity, it&#39;s certainly not <em>sufficient</em>: again, our goal is to bypass the compositor.</p>

<h1 id="resolutions--scaling">Resolutions &amp; Scaling</h1>

<p>A few days ago, I decided that it was time to finish setting up the video options for <a href="https://www.anthropicstudios.com/way-of-rhea">Way of Rhea</a>. I previously supported the following window modes (or, at least, I thought I did!):</p>

<ul>
	<li>Borderless window</li>
	<li>Windowed</li>
</ul>

<p>I didn&#39;t properly lock the aspect ratio in either of these which could lead to UI and/or game elements being off screen on some setups, so my first goal was to fix that. In doing so, I realized that <a href="https://twitter.com/masonremaley/status/1362331833237708806">it&#39;s kind of weird that most games only let you choose from a fixed set of resolutions</a>.</p>

<p>Traditionally this made sense&ndash;if you&#39;re going to mess with the display settings to get the resolution you want, then you can only support resolutions the display supports! However, if you&#39;re in borderless window mode which is becoming more and more common, you can set the resolution to anything you want since you&#39;re just resizing a framebuffer.</p>

<p>I figured, if fullscreen exclusive support is gonna dictate which resolutions I can support, maybe I should knock that out first. How hard could that be?</p>

<p>Well, you&#39;ve presumably already seen the title of this post and have a guess at what the answer to that question is. :)</p>

<h1 id="methods-of-enabling-fullscreen-exclusive-mode-in-opengl">Methods of Enabling Fullscreen Exclusive Mode in OpenGL</h1>

<p>Presumably DirectX has an API for this, but I&#39;m targeting OpenGL.</p>

<p>The internet is full of hearsay about what you need to do to get fullscreen exclusive mode in OpenGL. Some say that you need to apply the <code>WS_POPUP</code> window style, others say you need <code>WS_POPUP | WS_CLIPCHILDREN | WS_CLIPSIBLINGS</code>. Others claim you need to call <code>ChangeDisplaySettings</code> with <code>CDS_FULLSCREEN</code>.</p>

<p>There&#39;s a big issue with all of these claims: they&#39;re not documented, and there&#39;s no obvious way to test if they actually work!</p>

<p>If we&#39;re serious about doing things right, we need to find a way to test for fullscreen exclusivity.</p>

<h1 id="testing-if-were-fullscreen-exclusive">Testing If We&#39;re Fullscreen Exclusive</h1>

<p>I&#39;d love to be wrong about this, but as far as I can tell, Microsoft/NVIDIA/etc do not provide a way to directly check if a window is fullscreen exclusive. If you search around online for ways to test for exclusivity, you&#39;ll find more hearsay:</p>

<h2 id="tests-that-dont-work">Tests That Don&#39;t Work</h2>

<h3 id="volume-meter">Volume Meter</h3>

<p>People often check for exclusivity by changing the computer volume via a hot key and observing whether or not the volume overlay shows up on top of the game.</p>

<p>We can use this to rule out exclusivity (the volume meter won&#39;t show up if we&#39;re exclusive since we&#39;re bypassing the compositor), but we can&#39;t use it to prove exclusivity&ndash;I&#39;ve seen games that are clearly not exclusive manage to hide the volume meter anyway.</p>

<p>(I&#39;m actually rather curious how they accomplished this, if you know how to do this <a href="mason.remaley+pub@gmail.com">I&#39;d be interested in hearing from you</a>.)</p>

<h3 id="windows-key">Windows Key</h3>

<p>Another common suggestion is to check whether the Windows key works. I can see why people suggest this as a test&ndash;on some of my test machines, fullscreen exclusive windows <em>do</em> obscure the windows menu. However, this is not true on all of them, and if you&#39;re testing a game for which you don&#39;t control the source it&#39;s very likely that <a href="https://docs.microsoft.com/en-us/windows/win32/dxtecharts/disabling-shortcut-keys-in-games">the windows key was disabled manually by the game.</a></p>

<p>If you try this test yourself, you may notice that even on setups for which the windows menu is not obscured, it causes the window to flash black as it loses exclusivity&hellip;</p>

<h3 id="flashing">Flashing</h3>

<p>The last common suggestion I&#39;ve seen is to check whether the window/monitor flashes black when it loses focus. In my tests so far, fullscreen exclusive windows <em>will</em> flash when they lose focus, however, there are other potential sources of flashes&ndash;<code>ChangeDisplaySettings</code> for example can cause the monitor to flash even if no settings are changed, and many games call it when gaining/losing focus.</p>

<p>I&#39;ve managed to convince myself that can tell the difference between a flash due to losing exclusivity and a flash with another cause, but it&#39;s very subtle and not something I would want to rely on to check whether or not my game is working correctly!</p>

<h2 id="a-test-that-works">A Test That Works</h2>

<figure><img alt="way of rhea with the windows menu open" height="276" src="https://www.anthropicstudios.com/assets/monsters-and-sprites/fullscreen-exclusive-is-a-lie/windows-menu.png" width="505" />
<figcaption>It&#39;s not the classic windows key test&ndash;there&#39;s a little more to it.</figcaption>
</figure>

<p>It&#39;s not the classic windows key test&ndash;there&#39;s a little more to it.</p>

<p>Alright, we&#39;ve listed a number of methods that <em>don&#39;t</em> work. So what do we do?</p>

<p>If we&#39;re in fullscreen exclusive mode, we&#39;re bypassing the compositor. This means that things like print screen will not behave correctly.</p>

<p>In particular, if you have a fullscreen exclusive window, and you press the print screen shortcut, instead of getting a current screenshot you&#39;ll get a screenshot of *the last non-exclusive frame*. Normally this is a nuisance, but today we can take advantage of it!</p>

<p>The test is as follows:</p>

<ul>
	<li>Launch the possibly-fullscreen-exclusive game</li>
	<li>Move the camera to somewhere memorable</li>
	<li>Temporarily prevent the app from being exclusive, e.g. by pressing the Windows key twice to toggle the Windows menu on and off or obscuring part of the game with another window</li>
	<li>Once the game is back to its normal state, move the camera to a new location</li>
	<li>Press your print screen shortcut
	<ul>
		<li>It&#39;s important that you use print screen&ndash;don&#39;t take a screenshot with Steam for example, Steam can screenshot exclusive windows correctly</li>
	</ul>
	</li>
	<li>Check the resulting screenshot:
	<ul>
		<li>If the screen shot is up to date, you&#39;re not exclusive.</li>
		<li>If the screenshot is of the area of the game you were in while the windows menu/such was present, you&#39;re in exclusive mode! (the menu/window itself will not appear in the screenshot)</li>
	</ul>
	</li>
</ul>

<p><em>Please note: I can&#39;t promise Microsoft won&#39;t fix this someday, you&#39;ll have to test for yourself whether these results are reproducible on your version of Windows. If you&#39;re never able to get an out of date screenshot, it&#39;s either been fixed or you haven&#39;t tested a truely fullscreen exclusive app yet.</em></p>

<h1 id="testing-methods-of-gaining-fullscreen-exclusivity-in-opengl">Testing Methods of Gaining Fullscreen Exclusivity in OpenGL</h1>

<p>I tested out the various methods of gaining fullscreen exclusivity in OpenGL suggested online on 5 different setups. Here&#39;s what I found:</p>

<ul>
	<li>I&#39;ve never successfully gained exclusivity without the <code>WS_POPUP</code> window style</li>
	<li>I&#39;ve never observed the <code>WS_CLIPCHILDREN</code> or <code>WS_CLIPSIBLINGS</code> window styles making a difference</li>
	<li>I&#39;ve never observed calling <code>ChangeDisplaySettings</code> with <code>CDS_FULLSCREEN</code> making a difference
	<ul>
		<li>This shouldn&#39;t be too surprising&ndash;despite the name, according to <a href="https://docs.microsoft.com/en-us/windows/win32/api/winuser/nf-winuser-changedisplaysettingsa#CDS_FULLSCREEN">the docs</a> all it does is make the other settings changed by <code>ChangeDisplaySettings</code> temporary. <a href="https://devblogs.microsoft.com/oldnewthing/20080104-00/?p=23923">See also Raymond Chen</a>.</li>
	</ul>
	</li>
	<li>On all 5 setups, I can gain exclusivity at any resolution without without calling <code>ChangeDisplaySettings</code>
	<ul>
		<li>I just render to a framebuffer and upscale to the native resolution, just like in borderless window mode. Nothing about this requires the compositor.</li>
	</ul>
	</li>
	<li>On two of the five setups, I was unable to gain exclusivity without being <a href="https://docs.microsoft.com/en-us/windows/win32/hidpi/setting-the-default-dpi-awareness-for-a-process">DPI Aware</a>
	<ul>
		<li>Despite the overly confusing DPI Awareness API, this does make sense&ndash;if you render at the wrong DPI the compositor will need to scale your final result before it&#39;s displayed. On the setups where I didn&#39;t need to be DPI Aware, I had a &ldquo;normal&rdquo; DPI that required no scaling.</li>
	</ul>
	</li>
</ul>

<p>Okay, so things are looking good for <code>WS_POPUP</code> + DPI Awareness right? Well&hellip;</p>

<p><code>WS_POPUP</code> and DPI Awareness do appear to be <em>necessary</em> for exclusivity, but they&#39;re unfortunately not <em>sufficient</em>! On the setup that I expect is most similar to most player&#39;s setups (single monitor w/ an NVIDIA GPU) I wasn&#39;t able to figure out how to acquire fullscreen exclusivity at all.</p>

<p>Alright, this is kind of a mess! How the heck are other games doing it?</p>

<h1 id="testing-fullscreen-exclusivity-in-other-games">Testing Fullscreen Exclusivity in Other Games</h1>

<blockquote>
<p>Alright, this is kind of a mess! How the heck are other games doing it?</p>
</blockquote>

<p>&hellip;well apparently, they&#39;re not!</p>

<p>I&#39;ve tested 6 games so far ranging from well received graphically intensive indie games to larger well received AAA games that you would expect to care about this sort of thing.</p>

<p>I won&#39;t name the games as I don&#39;t want to criticize them in particular, the issue appears to be universal. Here are the &ldquo;anonymized&rdquo; results&ndash;I tested on the setup that I found to be the most forgiving in terms of allowing exclusivity:</p>

<table border="0">
	<tbody>
		<tr>
			<th>Scale</th>
			<th>Release Year</th>
			<th>Graphics API</th>
			<th>Engine</th>
			<th>Fullscreen is exclusive</th>
			<th>Borderless Window is exclusive</th>
		</tr>
		<tr>
			<td>Indie FPS</td>
			<td>2020</td>
			<td>DirectX</td>
			<td>Unity</td>
			<td>No</td>
			<td>No</td>
		</tr>
		<tr>
			<td>AAA TPS</td>
			<td>2020</td>
			<td>DirectX</td>
			<td>In House</td>
			<td>Yes</td>
			<td>Yes</td>
		</tr>
		<tr>
			<td>AA TP</td>
			<td>2014, but kept up to date</td>
			<td>DirectX/Vulkan</td>
			<td>In House</td>
			<td>No</td>
			<td>No</td>
		</tr>
		<tr>
			<td>AA FPS</td>
			<td>2020</td>
			<td>DirectX</td>
			<td>Unreal</td>
			<td>No</td>
			<td>No</td>
		</tr>
		<tr>
			<td>Indie FP</td>
			<td>2020</td>
			<td>DirectX</td>
			<td>In House</td>
			<td>Yes</td>
			<td>Yes</td>
		</tr>
		<tr>
			<td>AAA TPS</td>
			<td>2020</td>
			<td>DirectX</td>
			<td>In House</td>
			<td>No</td>
			<td>No</td>
		</tr>
	</tbody>
</table>

<p>&nbsp;</p>

<p>Of the 6 games tested, not a single one could reliably toggle fullscreen exclusivity. Four of the six never achieved exclusivity on my setup, and the remaining two were always exclusive when fullscreened&ndash;even when in borderless window mode.</p>

<p>Of note, this list contains a Unity game, an Unreal game, and four different proprietary engines.</p>

<p>The only thing the fullscreen exclusive option reliably does in the games listed is change your display resolution to match the game&ndash;and one of the six (AAA TPS 2020) didn&#39;t even do that.</p>

<h1 id="takeaways">Takeaways</h1>

<p>If nobody else has found a way to offer a reliable fullscreen exclusivity toggle, I see little reason to pretend that I offer that mode either!</p>

<p>In addition, since upscaling from a framebuffer seems to have no effect on exclusivity (and no measurable perf effect as compared to changing the monitor resolution), I have no reason to limit the resolutions at which my game can render.</p>

<p>Taking these observations into account, my plan is as follows:</p>

<ul>
	<li>Offer a borderless window mode</li>
	<li>Offer a windowed mode</li>
	<li>Offer a render scale option as a percent of the native resolution</li>
	<li>Offer the ability to resize the windowed mode window arbitrarily within the supported aspect ratios</li>
</ul>

<p>This will give technically adept players options without over promising, and should be less confusing than a large list of resolutions for everyone else.</p>

<p>I am conflicted as to whether or not I should use the <code>WS_POPUP</code> style in borderless window mode&ndash;on one hand, with it at least <em>some</em> players will get fullscreen exclusivity, OTOH those players then won&#39;t be able to use print screen. I&#39;ll likely end up doing what I do with vsync&ndash;making a checkbox for it, but labeling it as a &ldquo;hint&rdquo; to acknowledge that I as the developer don&#39;t actually have the final say as to whether or not the setting has any effect.</p>

<hr />
<p>If you enjoyed this post and want to read more posts like it in the future, you can follow me on <a href="https://www.gamasutra.com/blogs/MasonRemaley/1030304/" target="_blank">Gamasutra</a>, <a href="https://twitter.com/masonremaley" target="_blank">Twitter</a>, or <a href="https://www.anthropicstudios.com/newsletter/signup/tech">sign up for my newsletter</a>!</p>

            </div>   
                                                <hr>
                    <div class="hide-phone">
                        <h3>Related Jobs</h3>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/senior-software-engineer-performance-tooling-redmond-washington-35125"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1038730.png" alt="Xbox Graphics" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Xbox Graphics &mdash; 
                                                                          Redmond,
                                                                                                              Washington,
                                                                        United States
                                    <br />
                                    [06.30.21]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/senior-software-engineer-performance-tooling-redmond-washington-35125">Senior Software Engineer: Performance Tooling</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/senior-software-engineer-gpu-compilers-redmond-washington-35124"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/1038730.png" alt="Xbox Graphics" width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Xbox Graphics &mdash; 
                                                                          Redmond,
                                                                                                              Washington,
                                                                        United States
                                    <br />
                                    [06.30.21]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/senior-software-engineer-gpu-compilers-redmond-washington-35124">Senior Software Engineer: GPU Compilers</a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/experienced-technical-artist-games-bristol-england-35121"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/975560.jpg" alt="Aardman Animations Ltd " width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Aardman Animations Ltd  &mdash; 
                                                                          Bristol ,
                                                                                                              England,
                                                                        United Kingdom
                                    <br />
                                    [06.30.21]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/experienced-technical-artist-games-bristol-england-35121">Experienced Technical Artist (Games) </a>
                                </div>
                           </div>
                                                   <div class="stories_item">
                                <div class="thumb"><a href="https://jobs.gamasutra.com/job/lead-engineer-games-bristol-england-35120"><img src="https://d1506sp6x4e9z7.cloudfront.net/gamasutra/uploads/975560.jpg" alt="Aardman Animations Ltd " width="120"></a></div>
                                <div class="title">
                                    <strong>
                                    Aardman Animations Ltd  &mdash; 
                                                                          Bristol ,
                                                                                                              England,
                                                                        United Kingdom
                                    <br />
                                    [06.30.21]
                                   </strong>
                                   <br />
                                   <a href="https://jobs.gamasutra.com/job/lead-engineer-games-bristol-england-35120">Lead Engineer (Games) </a>
                                </div>
                           </div>
                                            </div>
                    <br class="clear"/><br/>
                    <div class="right small">
                        <strong>[<a href="https://jobs.gamasutra.com/">View All Jobs</a>]</strong>
                    </div>
                    <br class="clear"/><br/>
                                        <hr>
            							<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
																
								//Rectangle 1 on small mobile device
								if (document.documentElement.clientWidth <= 767)
								{ document.write('<div id="div-gpt-ad-rec1"><center>'); 
										googletag.cmd.push(function(){
											googletag.display('div-gpt-ad-rec1'); 
										});
										document.write('</center></div>'); }
								
							</script>


                <div id="dynamiccomments">
					<span id="cmtArticleId" style="display:none">377715</span>
					<span id="cmtStory_type" style="display:none">blog</span>
					<span id="cmtArticleUri" style="display:none">/blogs/MasonRemaley/20210222/377715/Fullscreen_Exclusive_Is_A_Lie_sort_of.php?utm_source=feedburner&utm_medium=feed&utm_campaign=Feed%3A+GamasutraNews+%28Gamasutra+News%29</span>
					<span id="author_id" style="display:none">1030304</span>
					<span id="author_user_id" style="display:none">27057273</span>
                    <a style="font-weight: bold; font-size: 16px;" name="comments"> Loading Comments</a>
                    <br />
                    <hr noshade size="1" class="hr_comment">
                
                    <div align="center">
                         <img style="padding-top: 2px; padding-right: 5px; padding-bottom: 5px;" alt="loader image" src="/ajax-loader.gif"/>
                    </div>
       
                </div>
                    </div>  
        <!-- InstanceEndEditable -->
    </div><!--end contentbox-->
</div><!--end span-16-->

            </div>
            <br class="clear">
	</div><!--end span-21-->

        <!--begin right sidebar-->
     	<div class="hide-phone center">
               <div class="span-4 last">
                   <!--right hand ads start here-->

  
                            <!-- Beginning Sync AdSlot 7 for Ad unit Gamasutra//consolepc ### size: [[160,600]]  -->
<div id='div-gpt-ad-sky1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-sky1');
	}
	);
 </script>
</div>
<!-- End AdSlot 7 -->
        <!-- Beginning Sync AdSlot 8 for Ad unit Gamasutra//consolepc ### size: [[160,160]]  -->
<div id='div-gpt-ad-Ltile1'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-Ltile1');
	}
	);
 </script>
</div>
<!-- End AdSlot 8 -->
      
		 
               	</div>
                 </div>
     <!--end right sidebar--> 
        <!-- </div> Extra Div -->
					<!-- Beginning Sync AdSlot 21 for Ad unit Gamasutra//consolepc ### size: [[8,2]]  -->
<div id='div-gpt-ad-native'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-native');
	}
	);
 </script>
</div>
<!-- End AdSlot 21 -->
			<!-- Beginning Sync AdSlot 22 for Ad unit Gamasutra//consolepc ### size: [[8,4]]  -->
<div id='div-gpt-ad-insight'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-insight');
	}
	);
 </script>
</div>
<!-- End AdSlot 22 -->
			<!-- Beginning Sync AdSlot 23 for Ad unit Gamasutra//consolepc ### size: [[4,4]]  -->
<div id='div-gpt-ad-video'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-video');
	}
	);
 </script>
</div>
<!-- End AdSlot 23 -->
		

     <br class="clear">
<link rel="stylesheet" type="text/css" href="https://twimgs.com/informationweek/footernav/jan2015/css/superfooter_dark.css" />
<link rel="stylesheet" type="text/css" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css" />
<link rel="stylesheet" type="text/css" href="https://twimgs.com/nojitter/css/common-footer.css?" />
<div align="center">
          <!-- Beginning Sync AdSlot 6 for Ad unit Gamasutra//consolepc ### size: [[3,3]]  -->
<div id='div-gpt-ad-ribbon'>
 <script type='text/javascript'>
    googletag.cmd.push(function() { 
		googletag.display('div-gpt-ad-ribbon');
	}
	);
 </script>
</div>
<!-- End AdSlot 6 -->
</div>

</div><!--end content-body-wrapper-->
     </div><!--end container-->
<!--begin footer-->
<style type="text/css">

@media (min-width: 992px){
	.col-md-5.discover {
		width:47%;
	}
	.divisional-footer .divisional-footer-container .col-md-2 ul{
		padding-right: 28%;
	}
	.col-md-5.brand-name {
		width:27%;
	}
	.col-md-6.logo{
		width: 48%;
		padding: 0.5% 0px;
	}
	.col-md-12 p{
		padding-left:40%;
	}
}

</style>
<footer id="#informa-footer">
        <div class="divisional-footer" style="/*padding-left:10px;padding-right:10px;*/max-width:none;">
            <div class="divisional-footer-container">
                <!--divisional plus marketing -->
                <div class="alternate">
                    <div class="footer-row" style="border-bottom: 1px solid #fff;">
                        <div class="col-md-5 discover">
                            <div class="heading">Discover more from Informa Tech</div>
                            <ul class="list-inline">
                                <li><a href="https://www.gdconf.com" title="Game Developers Conference" target="_blank">Game Developers Conference</a></li>
								<li><a href="https://igf.com/" title="Independent Games Festival" target="_blank">Independent Games Festival</a></li>
								<li><a href="https://jobs.gamasutra.com/" title="Gamasutra Jobs" target="_blank">Gamasutra Jobs</a></li>
								<li><a href="https://www.gamechoiceawards.com/" title="Game Developers Choice Awards" target="_blank">Game Developers Choice Awards</a></li>
								<li><a href="https://www.gdcvault.com/" title="GDC Vault" target="_blank">GDC Vault</a></li>
								<li><a href="https://www.omdia.com/" title="Omdia" target="_blank">Omdia</a></li>
								<li><a href="https://www.gamecareerguide.com/" title="Game Career Guide" target="_blank">Game Career Guide</a></li>
                            </ul>
                        </div>
                        <div class="col-md-2 working">
                            <div class="heading">Working With Us</div>
                            <ul class="list-inline">
								<li>
                                    <a href="https://www.gamasutra.com/contactus">Contact us</a>
                                </li>
                                <li>
                                    <a href="https://www.gamasutra.com/static2/howwework.html">About Us</a>
                                </li>
                                <li>
                                    <a
                                        href="https://www.gamasutra.com/advertise">Advertise</a>
                                </li>
                            </ul>
                        </div>
                        <div class="col-md-5 brand-name">
                            <div class="heading">Follow gamasutra on Social </div>
                            <ul class="list-inline social-icon">
                                <li>
                                    <a href="https://www.facebook.com/pages/Gamasutra/31610613408"><i
                                            class="facebook-white trigger-sc-event"
                                            data-goal-id="715A59A2-A9FC-44E0-B4AF-8A960F2A5116"></i></a>
                                </li>
                                <li>
                                    <a href="https://twitter.com/gamasutra"><i
                                            class="twitter-white trigger-sc-event"
                                            data-goal-id="715A59A2-A9FC-44E0-B4AF-8A960F2A5116"></i></a>
                                </li>
                                <li>
                                    <a href="https://www.gamasutra.com/static2/rssfeeds.html"><i class="rss-feed-white trigger-sc-event"
                                            data-goal-id="715A59A2-A9FC-44E0-B4AF-8A960F2A5116"></i></a>
                                </li>
                            </ul>
                        </div>
                    </div>
                </div>
                <!--DIV-->
            </div>
        </div>

        <div class="divisional-footer">
            <div class="divisional-footer-container">
                <div class="footer-row footer-icons">
                    <div class="col-md-6 logo" style="padding: 0.5% 0px;">
                        <img src="https://twimgs.com/nojitter/img/Whitelogo.png" alt="alt text of the logo">
                    </div>

                    <div class="col-md-6">
                        <ul class="list-inline">
							<li>
                                <a href="https://tech.informa.com/" target="_blank">Home</a>
                            </li>
                            <li>
                                <a href="https://tech.informa.com/cookie-policy" target="_blank">Cookies</a>
                            </li>
							<li>
                                <a href="https://privacyportal-eu-cdn.onetrust.com/dsarwebform/c1f53e84-9f05-4169-a854-85052b63c50b/5f26b553-52cc-4973-a761-295d5634a6b6.html" target="_blank">CCPA: Do not sell my personal info</a>
                            </li>
                            <li>
                                <a href="https://tech.informa.com/privacy-policy" target="_blank">Privacy</a>
                            </li>
                            <li>
                                <a href="https://tech.informa.com/terms-and-conditions" target="_blank">Terms</a>
                            </li>
                        </ul>
                    </div>
                </div>
                <div class="footer-row privacy-policy">
                    <div class="col-md-12">
                        <p class="copyright">Copyright &copy; 2021 Informa PLC
                            Informa UK Limited is a company registered in England and Wales with company number 1072954
                            whose registered office is 5 Howick Place, London, SW1P 1WG.
                        </p>
                    </div>
                </div>
            </div>
        </div>
    </footer>
<!--end footer-->

<script type="text/javascript">
	var registerData='';
	registerCheck();
	function registerCheck(){
		$.ajax({
			url: '/omnloginstatus.php',
			async : false,
			success: function(result){
				registerData = result.replace('"','');
				registerData = registerData.replace('"','');
			}
		});
	}
</script>

<script type="text/javascript" src="https://twimgs.com/nojitter/gama/js/oasTrack_v1.js"></script>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
<script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script>
<!-- SiteCatalyst code version: H.21.
Copyright 1996-2010 Adobe, Inc. All Rights Reserved
More info available at http://www.omniture.com -->

<script language="JavaScript" type="text/javascript" src="https://twimgs.com/custom/library.gtecevent.com/assets/ubm-tech-global-app-measurement.js?ormzkk"></script>
<script language="JavaScript" type="text/javascript"><!--
    /* You may give each page an identifying name, server, and channel on
    the next lines. */
	s.pageName="";
	s.server="";
	s.channel="";
	s.pageType="";
	s.prop1="";
	s.prop2="377715";
	s.prop3="Gamasustra | 377715 | Fullscreen Exclusive Is A Lie (...sort of)";
	s.prop4="Fullscreen Exclusive Is A Lie (...sort of)";
	s.prop5="GAMASUTRA BLOG";
	s.prop6="";
	s.prop7="Mason Remaley";
	s.prop8="userAgent";
	s.prop9="";
	s.prop10="";
	s.prop13="";
    s.prop19=registerData;
	s.contextData['Newsletter_signup'] ="";
	/* Conversion Variables */
	s.campaign="";
	s.state="";
	s.zip="";
	s.events="event5";
	s.products="";
	s.purchaseID="";
	s.eVar1="programming,console-pc,indie";
	s.eVar2="";
	s.eVar3="";
	s.eVar4="";
	s.eVar5="";
	/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
  var s_code = s.t(); if (s_code) document.write(s_code)//--></script>
<script language="JavaScript" type="text/javascript"><!--
    if (navigator.appVersion.indexOf('MSIE') >= 0) document.write(unescape('%3C') + '\!-' + '-')
//--></script><noscript><a href="http://www.omniture.com" title="Web Analytics"><img
src="http://cmp.112.2o7.net/b/ss/cmpglobalvista/1/H.21--NS/0"
height="1" width="1" border="0" alt="" /></a></noscript><!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: H.21. -->

<!-- Begin ADSNATIVE Code -->
<script type="text/javascript" src="https://static.adsnative.com/static/js/render.v1.js"></script>
<!-- End ADSNATIVE Code -->
<!--Begin Ad script for pixel -->

<script type="text/javascript">
    adroll_adv_id = "AJSB6AWABZB2RFHAOYSOZH";
    adroll_pix_id = "2RTKKW6YFBHIVKRM6FNJ4D";
    /* OPTIONAL: provide email to improve user identification */
    /* adroll_email = "username@example.com"; */
    (function () {
        var _onload = function(){
            if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
            if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
                document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
        };
        if (window.addEventListener) {window.addEventListener('load', _onload, false);}
        else {window.attachEvent('onload', _onload)}
    }());
</script>

<!--END Ad script for pixel -->


<script type="text/javascript">
  var isChrome = /Chrome/.test(navigator.userAgent) && /Google Inc/.test(navigator.vendor);
  if(isChrome) {
    setInterval(function(){
      if(ngcheckLoggedIn()) {
        sessionAlive();
      }
    }, 180000); // 3 mins of interval
    function sessionAlive() {
      $.ajax({
        url: '/sessionAjax.php',
        success: function(){}
      });
    }
  }
</script>

</body>
</html>                
                